Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Online Forums > HLO - Pathfinder 2nd Edition

Notices

Reply
 
Thread Tools Display Modes
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 188

Old February 15th, 2021, 08:22 AM
I've been running a 2e game recently (5 sessions now) and I've noticed that almost every single monster I import from the vault has something wrong that I need to manually correct. I began to notice this on my 3rd session.

Typically it's been AC, attack bonuses, and DC's. Sometimes the creatures level is wrong/missing, and adjusting that corrects it. Sometimes I just need to add 1 AC or attack bonus. The time I noticed an incorrect DC I had no way to adjust it, and just had to remember. Everything that has been incorrect, has only been incorrect by 1.

Has anyone else noticed this?

I haven't reported any bugs on this yet, as it seems silly to submit a bug report for every single monster.

Realmworks Template Management
nightpanda2810 is offline   #1 Reply With Quote
dacoobob
Senior Member
 
Join Date: Sep 2018
Posts: 260

Old February 15th, 2021, 01:40 PM
which monsters, specifically? were they from Bestiary 1, 2, or both?
dacoobob is offline   #2 Reply With Quote
mototom
Senior Member
 
Join Date: Sep 2014
Location: Portland, OR
Posts: 170

Old February 15th, 2021, 09:27 PM
I'm pretty sure I've seen it in both. Virtually all of them had problems. I filed a bug report on the first few, but it really seems like a systemic problem—if they solve one of the AC problems, they'll likely solve them all.

They all look correct in the summary when you find them in the Vault. Once imported to my cast or scene, the AC is almost always different by 1. As nightpanda said, sometimes the issue is attack bonus or DCs. But I've seen the most problems with AC.
mototom is offline   #3 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 188

Old February 16th, 2021, 05:02 AM
Quote:
Originally Posted by dacoobob View Post
which monsters, specifically? were they from Bestiary 1, 2, or both?
I haven't deleted my old scenes, so I went through them all. Using Archives of Nethys for reference. I checked one or 2 against the books in-session and they matched the Archives.

All the ones I've seen so far have been B1.

Zombie Brute: Attack bonus off by 2.
Kobold Dragon Mage: Claw attack off by 4. Arcana by 1. Dragon lore by 1.
Kobold Scout: AC off by 1, Saves by 1, Attacks by 1, Skills by 1, Crafting by 3. (This guy's level says 0, but its 1)
Kobold Warrior: AC off by 1, Sling attack by 4, Spear melee by 3, Spear ranged missing.
Spider Swarm: AC off by 1, Athletics is reversed (-2 instead of +2).
Hunting Spider: Level is 0, so anything level based off by at least 1. Hunting spider venom DC off by 1.
Hobgoblin Soldier: Level is 0, so anything level based off by at least 1.
Cockatrice: Calcification DC off by 1, AC by 1.
Goblin Warrior: AC off by 1
Animated Statue: AC off by 1.
Gray Ooze: This one looks fine.
Shadow: AC off by 1.
Vampire Spawn: AC off by 1, Athletics 1, Intimidation 1, Society 8.
Skeletal Champion: AC off by 1.
Skeleton Guard: AC off by 1, Athletics 1.
Skeletal Giant: This one looks fine.


Bonus:
Zombie Hulk: Hunk of Meat attack bonus off by 8.

That's A LOT of discrepancies. My combat prep times have basically doubled, since I now need to double-check everything.

Quote:
Originally Posted by mototom View Post
I'm pretty sure I've seen it in both. Virtually all of them had problems. I filed a bug report on the first few, but it really seems like a systemic problem—if they solve one of the AC problems, they'll likely solve them all.

They all look correct in the summary when you find them in the Vault. Once imported to my cast or scene, the AC is almost always different by 1. As nightpanda said, sometimes the issue is attack bonus or DCs. But I've seen the most problems with AC.
Good catch, didn't notice myself until now.

Realmworks Template Management
nightpanda2810 is offline   #4 Reply With Quote
dacoobob
Senior Member
 
Join Date: Sep 2018
Posts: 260

Old February 16th, 2021, 08:36 AM
yikes, now i'm paranoid that i've been using the wrong numbers in the game i'm running. i'll double-check everything when i get home tonight. thanks for bringing this up!

if i were you i'd file a single bug report with all the info you've posted here. like mototom said, it seems like a systematic issue.
dacoobob is offline   #5 Reply With Quote
dacoobob
Senior Member
 
Join Date: Sep 2018
Posts: 260

Old February 18th, 2021, 09:09 AM
ok i checked and yes, i'm seeing the same issue. the monster stats are listed correctly in the preview pane on the Import From Vault menu, but once the monster is imported to the campaign cast the stats change! weird.

did you submit a bug report?
dacoobob is offline   #6 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 188

Old February 18th, 2021, 12:50 PM
Quote:
Originally Posted by dacoobob View Post
ok i checked and yes, i'm seeing the same issue. the monster stats are listed correctly in the preview pane on the Import From Vault menu, but once the monster is imported to the campaign cast the stats change! weird.

did you submit a bug report?
Haven't gotten around to it yet. Probably in the next few days.

Realmworks Template Management
nightpanda2810 is offline   #7 Reply With Quote
mototom
Senior Member
 
Join Date: Sep 2014
Location: Portland, OR
Posts: 170

Old February 18th, 2021, 08:49 PM
I've submitted a few for the AC changes.
mototom is offline   #8 Reply With Quote
Bioroid
Junior Member
 
Join Date: Jan 2021
Posts: 2

Old February 19th, 2021, 02:24 PM
Quote:
Originally Posted by nightpanda2810 View Post
I've been running a 2e game recently (5 sessions now) and I've noticed that almost every single monster I import from the vault has something wrong that I need to manually correct. I began to notice this on my 3rd session.

Typically it's been AC, attack bonuses, and DC's. Sometimes the creatures level is wrong/missing, and adjusting that corrects it. Sometimes I just need to add 1 AC or attack bonus. The time I noticed an incorrect DC I had no way to adjust it, and just had to remember. Everything that has been incorrect, has only been incorrect by 1.

Has anyone else noticed this?

I haven't reported any bugs on this yet, as it seems silly to submit a bug report for every single monster.
I have seen this as well. I have not had time to report them as of yet myself, as they are sometimes hard to spot until I am in the middle of a session. But Best 1 has quite a few.
Bioroid is offline   #9 Reply With Quote
Daniel V
Senior Member
Lone Wolf Staff
 
Join Date: Apr 2020
Posts: 128

Old February 22nd, 2021, 11:03 AM
This is something we're actively looking into. A fair bit originates from adjustments made between the B1 release and when monster creation rules were put out in the GMG, and some are just issues lol. But yeah, we're working to address it and make corrections.
Daniel V is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:29 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.