Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - Shadowrun

Notices

Reply
 
Thread Tools Display Modes
Ech0
Member
 
Join Date: Jul 2014
Posts: 41

Old May 29th, 2016, 08:56 AM
Hey folks,

I'm having trouble figuring out how to correctly use the new Rigger rules without causing error messages left and right. Here's what I've tried to do:

I have bought a Roto Drone that I rigged (ha) with a spotlight and a pilot upgrade to rating 5 plus appropiate Autosofts (Maneuver, Smartsoft and Targeting) on rating 5.

Now I try to buy a RCC (the Essy DroneMaster) and add Autosofts rating 5, but this results in an error that's telling me

"Clearsight: A Pilot Programm may not run an autosoft of a higher Rating than itself (2)."

I do not get an error when I add Clearsight rating 2; rating 3 and upwards causes errors.

While I do get the rules from Rigger V that may cause this problem, there isn't a Pilot rating of 2 anywhere to be seen. Nor a device rating or 2.

What am I doing wrong?


Edit: I'd tried adding various RCCs, cars and drone (or non whatsoever) - whenever I add an Autosoft higher than rating 2, I get an error.

Last edited by Ech0; May 29th, 2016 at 09:54 PM.
Ech0 is offline   #1 Reply With Quote
BrotherPrætus
Junior Member
 
Join Date: Jun 2015
Location: Phoenix, PCC
Posts: 28

Old May 30th, 2016, 03:18 AM
Well, first things first. A drone may still only use the Autosofts loaded on the RCC if it is not running any Autosofts on itself (corebook, p267 under Noise Reduction & Sharing). There is nothing in Rigger 5.0 which alters that facet of their functions.

Otherwise, I've seen this sort of thing when working on Rigger concepts. I haven't figured out a work around or why it seems to not want to play nice with RCCs.
BrotherPrætus is offline   #2 Reply With Quote
Mathias
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 12,927

Old June 1st, 2016, 09:55 AM
Ech0 - that's a bug. Others have beat you to reporting it, so it'll be fixed in the next update. I forgot to add the "vehicles only" test when implementing the rule from Rigger 5.0 that says a vehicle can't run autosofts at a higher rating than its pilot rating.
Mathias is offline   #3 Reply With Quote
Ech0
Member
 
Join Date: Jul 2014
Posts: 41

Old June 1st, 2016, 10:28 AM
Thanks for the reply, I felt a tad bit stupid. :-)

I'll send you another bug report in a sec - for a different one, though.
Ech0 is offline   #4 Reply With Quote
adzling
Senior Member
 
Join Date: Apr 2015
Posts: 343

Old June 1st, 2016, 10:39 AM
urm drones cannot run autosofts higher than their pilot rating either.
+ they also cannot run more autosofts than their rating...

Quote:
Originally Posted by Mathias View Post
Ech0 - that's a bug. Others have beat you to reporting it, so it'll be fixed in the next update. I forgot to add the "vehicles only" test when implementing the rule from Rigger 5.0 that says a vehicle can't run autosofts at a higher rating than its pilot rating.
adzling is offline   #5 Reply With Quote
Ech0
Member
 
Join Date: Jul 2014
Posts: 41

Old June 5th, 2016, 12:44 PM
Another thing in regards to drones and RCCs:

Shopping seems to be broken. Whenever I buy a drone for one of my chars, HeroLab fails to deduct the costs for modifications (weapons, upgrades etc) of said drones. The cost of the drone is set to "0".


*already reported - if you add a custom price, it seems to work!

Last edited by Ech0; June 5th, 2016 at 12:53 PM.
Ech0 is offline   #6 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 10:01 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.