Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - 4th Edition

Notices

Reply
 
Thread Tools Display Modes
tpkurilla
Member
 
Join Date: Aug 2009
Posts: 52

Old February 23rd, 2010, 10:02 PM
I have every book, supplement, and magazine enabled for building my Artificer character, but when I select the Arcane Implement Proficiency feat, the only choices I get are: Holy Symbol, Ki Focus, Orb, Pact Blade, Rod, Staff, Totem, and Wand.

The 4e Character Builder says that my choices are: Dagger, Heavy Blade Group, Light Blade Group, Orb, Rod, Staff, Tome, and Wand, since these are implements usable by Arcane classes.

I've started trying to dig into the data files to find where I can correct this, but haven't figured it out yet.

Any ideas as to why the choices are so wrong, and how I can fix them?

Thanks in advance,

-Thomas
tpkurilla is offline   #1 Reply With Quote
tpkurilla
Member
 
Join Date: Aug 2009
Posts: 52

Old February 24th, 2010, 05:25 PM
Okay, I think I've nailed it down.

thing_gear.dat has hard-coded entries for "ImplemType", and matches the selections that I'm given exactly.

It seems like for a general long-term solution we'll need a compset of "ArcaneImpl" that gets arcane class-specific implements added to it as the ddidownloader gets arcane classes.

For now, I can add a .user file to cover the arcane implements, and perform surgery by hand on the "Arcane Implement Proficiency" to reference the "ArcaneImpl" compset instead of the "ImplemType" it currently does.

Is there a better way?

Edit: This didn't work. My HLscript-fu is not strong. For now I'll create a feat specific to each arcane implement, and replace the ddidownloader feat with these.

-Thomas

Last edited by tpkurilla; February 24th, 2010 at 06:04 PM. Reason: Discovered the weakness of my script-fu...
tpkurilla is offline   #2 Reply With Quote
tpkurilla
Member
 
Join Date: Aug 2009
Posts: 52

Old February 24th, 2010, 05:50 PM
Hmm, seems like the Sorcerer doesn't have Daggers listed as implements in the ddidownloader files.

So I guess that's another bug to look into. (assuming that I'm doing the checking correctly...)

-Thomas
tpkurilla is offline   #3 Reply With Quote
Colen
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2008
Posts: 4,718

Old March 3rd, 2010, 02:30 PM
Thanks, I hadn't realised the feat needed to be updated. I'll get this fixed and make sure Sorcerers have the correct implements for the next release.
Colen is offline   #4 Reply With Quote
DaveWilli
Junior Member
 
Join Date: Sep 2011
Posts: 2

Old September 6th, 2011, 06:29 AM
Did this ever get fixed, because I am having the same problem with a new purchase and recent DDI Download.

A little more info, have a cosmic sorc, for Implement Focus and Implement Expertice do not see light blades or dagger in dropdown, closest is Pact Blade

Last edited by DaveWilli; September 6th, 2011 at 07:35 AM. Reason: More Info
DaveWilli is offline   #5 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:39 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.