Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old March 31st, 2015, 08:55 PM
When I started using RW I didn't know about containers (I tend to jump in and not read directions unless I have major problems) so the topics I created stayed in their categories. At Gen Con last year Rob showed me how to do containers. Of course I was even more impressed with the program. The top level containers stayed in their categories which was fine with me. I could click easily on the category to make a new topic if it was the same category. I also had the prefix before the name and sorted by prefix.

With this latest update if I select to organize similar kinds of topics the top level containers stay in their category but the contents do not sort by prefix. They sort by similar kind then by topic. Is this a bug or something I have to get use to?

If it's permanent there are some major problems with this. To have everything sorted by prefix I have to uncheck organize similar kinds of topics but I can't collapse anything. This means that when I need to open a specific topic that is toward the bottom of a LOOOONG list I'm not very happy doing this over and over. And I DO NOT want to click on each handle to collapse each individual container.

So I'm hoping this is a bug and will be fixed with the next update. If it's not I am going to be very grumpy while using the program until you finally realize that we need to be able to have contents stay collapsed, preferably with just the ones we want open, whenever we start the program and whenever we create a new tab.
ruhar is offline   #1 Reply With Quote
Parody
Senior Member
 
Join Date: Jan 2013
Location: Rochester, MN
Posts: 1,406

Old April 1st, 2015, 07:51 AM
Hmm...I'm sure we had a good conversation about this in the past, but I can't find it. In any case it's been around for a long time.

Parody is offline   #2 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 1st, 2015, 11:34 AM
Quote:
Originally Posted by Parody View Post
Hmm...I'm sure we had a good conversation about this in the past, but I can't find it. In any case it's been around for a long time.
I couldn't find anything about it either. Are you sure the way it's organizing has been around for awhile because I really don't remember container contents organizing by topic before prefix or title before last night (I haven't had a chance to work on my stuff since the latest updates).
ruhar is offline   #3 Reply With Quote
Parody
Senior Member
 
Join Date: Jan 2013
Location: Rochester, MN
Posts: 1,406

Old April 1st, 2015, 02:20 PM
I remember people complaining about Realm Works not sorting properly when you turn off Organize Similar Kinds Of Topic/Article, but my memory of it is vague and I can't find references so I'm probably way off the mark somewhere. Sorry about that. :(

Parody is offline   #4 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 1st, 2015, 07:48 PM
This is not working. I have tried clicking off and on the different options and there are no configurations that will show one specific container with the topics in the correct order by prefix. The order RW puts it in is: E 2-1, E 2-1B, E 2-2, E 3A, E 4A, E 5, E 1, E 4B. "E 1" is suppose to be the first topic and "E 4B" should come before "E 5" instead of at the end but they are actually grouped in similar topic. I have tried retyping the prefix in case I had an extra space or something and it didn't work. Any ideas?
ruhar is offline   #5 Reply With Quote
AEIOU
Senior Member
 
Join Date: Jan 2012
Posts: 1,147

Old April 1st, 2015, 08:12 PM
Put a zero in front of single digits and perhaps dump the space? E01, E02-1, E02-1B....
AEIOU is offline   #6 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 1st, 2015, 08:19 PM
Quote:
Originally Posted by AEIOU View Post
Put a zero in front of single digits and perhaps dump the space? E01, E02-1, E02-1B....
Good suggestion but neither deleting the space nor replacing the space with a zero made it sort correctly.

I am only using 1-5 so it wouldn't matter if I kept the space, removed it or replaced it with a zero.
ruhar is offline   #7 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 740

Old April 2nd, 2015, 02:07 AM
Depending on the sorting algorithm non-alphanumeric signs might come before nothing.

So maybe:
E01-00
E02-10
E02-1B
E02-20
E02-3A
E02-4A

Or however it is you want to sort it - honestly, I am confused about your sorting...

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #8 Reply With Quote
Parody
Senior Member
 
Join Date: Jan 2013
Location: Rochester, MN
Posts: 1,406

Old April 2nd, 2015, 05:28 AM
Interesting. The worst I can make it do while set to "Sort Topics/By Prefix" is put the "E 2-(whatever)s" in front of "E 2", which is a sort failure to me. (Shorter terms should sort before longer ones that start the same.) It's inconsistent: "E 2-1B" sorts before "E 2" sorts before "E 2+1B"; "E 3" sorts before "E 3A". Weird.

In any case, if you have it set to "Sort Topics/Alphabetically" while also having "Show Prefix Before Name When Available" it looks completely wrong but sorts correctly. (Even "Incident 02" and "Incident 02-A" sorted properly.)

Here's my (hastily thrown together) sample data:

Sorting.png

Parody is offline   #9 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 2nd, 2015, 08:20 AM
I know my sorting is a little weird and there was a method to the madness. lol As I looked at it I realized that the "E #" could be containers for the "E #-X" so I did that. I even removed or simplified the prefix of the ones going into the containers. However, it did not fix "E 1". It still goes to the bottom as if it's being sorted by similar types kinds of topics. I did send a bug notice last night after changing things didn't make a difference. Here is what I have now:
Attached Images
File Type: jpg prefix-sorting.jpg (164.9 KB, 92 views)
ruhar is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 07:38 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.