Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - Savage Worlds

Notices

Reply
 
Thread Tools Display Modes
naloth
Member
 
Join Date: Sep 2006
Posts: 61

Old April 3rd, 2023, 06:55 AM
I'm planning on a Supers game using the 2022 Supers Companion and the recent SWADE rules.

It looks like the data files in the demo still use the Adventure edition (notably 15 skills, rather than the 5 default + 12 to spent) ?
naloth is offline   #1 Reply With Quote
CapedCrusader
Senior Member
Volunteer Data File Contributor
 
Join Date: Aug 2009
Posts: 1,548

Old April 3rd, 2023, 11:18 AM
The Super Powers Companion material in Hero Lab has not been updated to SWADE rules yet. The core material has been, which should include the 5 default Skills +12 points. Where are you still seeing 15?

_
Currently In Development: Savage Pathfinder
Future Development: SWADE Super Powers Companion, SWADE Fantasy Companion
_
Currently Running: Savage Unity Inc. (homebrew multiverse theme)
Setting Files Supported: Deadlands: Reloaded, Flash Gordon, Gaslight, Hellfrost, Interface Zero 2.0, Seven Worlds, Slipstream, Solomon Kane
Future Setting Files: Savage Judge Dredd
CapedCrusader is online now   #2 Reply With Quote
naloth
Member
 
Join Date: Sep 2006
Posts: 61

Old April 3rd, 2023, 11:43 AM
I loaded the Savage Worlds with Source (6.1); however, I believe I figured out the issue. It has the "Adventure" option greyed out for character selection. I'm guessing the demo locks you into the prior ruleset?
naloth is offline   #3 Reply With Quote
CapedCrusader
Senior Member
Volunteer Data File Contributor
 
Join Date: Aug 2009
Posts: 1,548

Old April 4th, 2023, 01:03 AM
Greyed out but selected? That's the latest rules edition, SWADE - Savage Worlds ADventure Edition. With that and the Super Powers Companion 2nd Edition selected, you'll have the 12 Skill points and the 5 default Skills, but the Super Powers will still be the prior edition. But as far as the demo version locking you to the prior ruleset, not that I'm aware of.

_
Currently In Development: Savage Pathfinder
Future Development: SWADE Super Powers Companion, SWADE Fantasy Companion
_
Currently Running: Savage Unity Inc. (homebrew multiverse theme)
Setting Files Supported: Deadlands: Reloaded, Flash Gordon, Gaslight, Hellfrost, Interface Zero 2.0, Seven Worlds, Slipstream, Solomon Kane
Future Setting Files: Savage Judge Dredd

Last edited by CapedCrusader; April 4th, 2023 at 01:05 AM.
CapedCrusader is online now   #4 Reply With Quote
naloth
Member
 
Join Date: Sep 2006
Posts: 61

Old April 4th, 2023, 10:44 AM
Greyed out, not selected. If I try it gives me the message: "This setting cannot be used because it requires a package that you do not have authorization for."

I can take a screenshot but I don't really know a way to attach them here. Besides, it sounds like it wouldn't work for the game I'm getting ready for, which was really the point of the original question. I'll check back periodically to see how the Supers datafile is coming.
naloth is offline   #5 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 10:57 AM.


Powered by vBulletin® - Copyright ©2000 - 2024, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.