View Single Post
Junior Member
Join Date: Nov 2018
Posts: 1

Old November 12th, 2018, 12:08 PM
Hello Guys, Just need a little help here. I have an Ipad mini that I have been using for gaming for quite a while now. It's primary purpose is for gaming. So last week I did the latest update, I no longer have an Ipad for gaming. I guess that is ok. However when I looked at the summary of the update, I do not recall a warning that it would render a completely functional device that I was happy with in to a non usable device. I guess that is ok. I understand that technology moves forward, and new software hits a point where backwards compatibility is just not possible. that is ok. However, being a user of an older device that is using a version of software that has reached it's EOL, it would have been nice to have a little warning. A summary that stated in very simply "Warning Read" prior to install. I was happy with the product that I had, it did what I wanted it to do. so now I am thinking what next? Try to export my characters to my home computer and look for an archived copy of the earlier version? Nope. there does not seem to be an earlier archive, anywhere. Ok Go out and by a new Ipad to replace one that worked just fine so that I can have the convenience of this application? Really? Not gonna happen. This can go on, but to get to the heart of what this is all about, it sure would be nice to have an archived copy of the last version that worked so that I could restore usability of my device. I understand that it would be unsupported and I am ok with that. It is that at this point, I have a license that I can not use, and a device that 'can' do what I bought the license for, but the two parts no longer fit together. I am not angry about this, just looking for a way to use this product without spending a couple hundred bucks that I will not spend. It kind of feels like being held hostage. "You can no longer use this product, that you have already spent over one hundred dollars on, until you spend a couple hundred more!" Is there a work around out there? What about the online version? Which by the way only works when WIFI is available, awesome, but better than nothing. Suggestions?
Aetrox is offline   #4 Reply With Quote