Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Army Builder (http://forums.wolflair.com/forumdisplay.php?f=16)
-   -   Possible timing bug when loading files? (http://forums.wolflair.com/showthread.php?t=12445)

Spack February 15th, 2011 04:33 AM

Possible timing bug when loading files?
 
An odd bug report on the AB40k site has popped up, and in looking into it further I've found I can get AB3.3 to load the roster correctly using the Load button on the game system dialog, but it won't load correctly using the File > Load roster option. Do these two load routines using different processing for handling the files? Is this an AB bug? Details including a roster file that is showing this glitch can be found here: http://www.ab40k.org/tracker.php?p=27&t=1952

shaggai February 15th, 2011 02:07 PM

Note I did some testing with the debug links on and found that there is a gnSpace with a priority of "10" and an visibility of yes(9999) and enablement of yes(9999). The unit in question does not even have this link and I guess that it is coming from somewhere else?

Note that the Pink Horrors also have that same type of text output on gnSpcAddUn - I was able to correct this by removing the ruleset.b_format from the live, but still doesn't affect the initial result when first loaded.

An additional note - when switching (any) ruleset to enabled and then disabled, the entire roster validated nominally.

Colen February 23rd, 2011 09:38 AM

Ugh, this is weird. Thanks for the report - I'll take a look at this.

Colen February 23rd, 2011 12:06 PM

OK, after a bit of investigation. Is the intent of the "for AB 3.2" ruleset to be always enabled? If so, you should simply delete the "legality" expression of that ruleset ("ro_bFormat"), and this problem will go away. The legality expression is currently:

Code:

roster.?
Which strikes me as odd - if you want it to always be active, you can just specify no expression at all. Is there a reason you can't do this?

AB appears to be not selecting the ruleset properly when the file is loaded, which I'm investigating now. But I can't think of a reason you can't just delete the tag expression and have everything work.

Hope this helps! :)


All times are GMT -8. The time now is 09:47 AM.

Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.