Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - Authoring Kit

Notices

Reply
 
Thread Tools Display Modes
TCArknight
Senior Member
 
Join Date: Jan 2007
Location: NW Arkansas
Posts: 930

Old October 22nd, 2017, 10:18 AM
I am having an issue with a chooser_table and a choosesortset.

Portal:
Code:
           
  <portal
    id="hoSpecies"
    style="chsNormal"
    width="110">
    <chooser_table
      component="Species"
      choosetemplate="SimpleItem"
	  choosesortset="SpecSort">
      <chosen><![CDATA[
        if (@ispick = 0) then
          @text = "{text clrwarning}Select Species"
        else
          @text = "Species: " & field[name].text
          endif
        ]]></chosen>
      <titlebar><![CDATA[
        @text = "Choose the Species for your character"
        ]]></titlebar>
      </chooser_table>
    </portal>
SpecCat tag:
Code:
  <!-- Species Cat group -->
  <group
    id="SpecCat"
    sequence="explicit">
    <value id="Player" order="10"/>
    <value id="NPC" order="20"/>
   </group>
Sortset (in control.1st):
Code:
  
  <!-- SpecSort - Species sortset -->
  <sortset id="SpecSort" name="Species Sort">
    <sortkey isfield="no" id="SpecCat"/>
    <sortkey isfield="no" id="_Name_"/>
    </sortset>
Species:
Code:
  <thing id="spcHdrPlay" name="Player" compset="Species" uniqueness="unique" isshowonly="yes">
    <usesource source="ENT"/>
    <usesource source="TOS"/>
    <usesource source="TNG"/>
    <tag group="SpecCat" tag="Player"/>
    <tag group="SimpleItem" tag="CenterName"/>
    </thing>

  <thing id="spcHdrNPC" name="NPC" compset="Species" uniqueness="unique" isshowonly="yes">
    <usesource source="ENT"/>
    <usesource source="TOS"/>
    <usesource source="TNG"/>
    <tag group="SpecCat" tag="NPC"/>
    <tag group="SimpleItem" tag="CenterName"/>
    </thing>

  <thing id="spcAndor" name="Andorian" description="desc here" compset="Species" uniqueness="unique">
    <usesource source="ENT"/>
    <usesource source="TOS"/>
    <usesource source="TNG"/>
    <tag group="SpecCat" tag="Player"/>
    <tag group="SpeciesBon" tag="attrsys02"/>
    <tag group="SpeciesBon" tag="attrsys01"/>
    <tag group="SpeciesBon" tag="attrsys05"/>
    <bootstrap thing="trAndorian"></bootstrap>
    </thing>

  <thing id="spcKlingon" name="Klingon" description="desc here"  compset="Species" uniqueness="unique">
    <usesource source="ENT"/>
    <usesource source="TOS"/>
    <usesource source="TNG"/>
    <tag group="SpeciesBon" tag="attrsys05"/>
    <tag group="SpecCat" tag="NPC"/>
    <tag group="SpeciesBon" tag="attrsys02"/>
    <tag group="SpeciesBon" tag="attrsys03"/>
    <bootstrap thing="trKlingon"></bootstrap>
    </thing>
This all results in the PLAYER header at the top, no NPC header, and NPC species grouped with Player species (and even though PLAYER and NPC are isshowonly="yes", unless I add the SimpleItem.CenterName tag, they don't show centered like normal): https://www.dropbox.com/s/ysg0li8r49...10-22.png?dl=0
Code:
PLAYER
ANDORIAN
HUMAN
KLINGON
TRILL
VULCAN
Anyone else had this happen? Am I missing something?

Thanks!
TC

Last edited by TCArknight; October 22nd, 2017 at 10:21 AM.
TCArknight is online now   #1 Reply With Quote
Mathias
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 12,239

Old October 22nd, 2017, 10:37 AM
I don't see anything wrong. Check the tags in your species compset - do you have SpecCat.Player being assigned as a component tag?
Mathias is offline   #2 Reply With Quote
TCArknight
Senior Member
 
Join Date: Jan 2007
Location: NW Arkansas
Posts: 930

Old October 22nd, 2017, 08:11 PM
::sigh:: I have to chalk this one up to an Id10T error...

I had a different portal, stSpecies buried in the form_static.dat file and was using it in my layout instead of the intended hoSpecies portal. Hopefully this will help others if they do something similar... lol
TCArknight is online now   #3 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 07:08 PM.


Powered by vBulletin® - Copyright ©2000 - 2018, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.