Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - D&D 5th Edition SRD

Notices

Reply
 
Thread Tools Display Modes
Mergon
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 749

Old August 1st, 2016, 11:42 AM
Quote:
Originally Posted by daplunk View Post
I highly recommend the We Be Goblins modules with the newly added Goblin race. Lots of fun
You realize it souns like you just volunteered to add it to HL?


Watch your back, Conserve your ammo,
and NEVER cut a deal with a dragon!
Mergon is offline   #211 Reply With Quote
ShadowChemosh
Senior Member
Volunteer Data File Contributor
 
Join Date: Jan 2010
Location: Chicago, IL (USA)
Posts: 10,700

Old August 1st, 2016, 02:33 PM
Quote:
Originally Posted by Necroblivion View Post
Good day gents. I just downloaded the 5e Community Pack today, and I can't seem to get it to work. I see that it's there, and I see the files, but I have no options to configure for it.

I also got the following error messages when loading:

The data files could not be loaded due to errors. Hero Lab will now attempt to load them in recovery mode. Once loaded, you can access the editor as normal to correct any errors.

The following errors occurred:

File: 5eExtras.user (line 34) - Thing - Invalid unique id 'rBRI?' for attribute 'id'
File: 5eExtras.user (line 53) - Thing - Invalid unique id 'rBRI?' for attribute 'id'
This issue is coming from your own personal files as the community Pack has no file called 5eExtras.user. What you did was appear to do a "New Copy" of something to look at and the editor adds in the "?" at the end. Making it an invalid Unique ID. If you saved the file and then restarted HL "then" the issue will show up.

Start the editor and open file "5eExtras.user". I would assume the above is a "Race" so look at the race tab. And either "fix" the Unique ID to not have a "?" or delete the whole Thing if you don't need it.

Restart HL and you should be good...

Hero Lab Resources:
Pathfinder - d20pfsrd and Pathfinder Pack Setup
3.5 D&D (d20) - Community Server Setup
5E D&D - Community Server Setup
Hero Lab Help - Hero Lab FAQ, Editor Tutorials and Videos, Editor & Scripting Resources.
Created by the community for the community
- Realm Works kickstarter backer (Alpha Wolf) and Beta tester.
- d20 HL package volunteer editor.
ShadowChemosh is online now   #212 Reply With Quote
daplunk
Senior Member
 
Join Date: Jan 2016
Location: Adelaide, Australia
Posts: 2,227

Old August 1st, 2016, 03:07 PM
@Mergon This last release already has everything needed

Here's a *.por file with the 5E versions of the PCs. The modules can all be found for free as they release on FreeRPG day (June 18th) annually.

https://drive.google.com/file/d/0B_6...ew?usp=sharing
daplunk is online now   #213 Reply With Quote
Necroblivion
Junior Member
 
Join Date: Jun 2012
Location: Waterloo, IA
Posts: 3

Old August 1st, 2016, 03:47 PM
@ShadowChemosh

That worked! Thank you very much.
Necroblivion is offline   #214 Reply With Quote
Dervish
Senior Member
 
Join Date: May 2013
Location: Grand Forks ND
Posts: 128

Old August 3rd, 2016, 08:52 PM
Goblin pantheon issue. As i was working on my own user file i noticed that the goblin pantheon was for some reason getting mixed with custom pantheon. looking through Com_5ePack_PHB - Deities.user none of the Goblin Deities were assigned Deity Catagory Order Group. For those people who notice and want to correct the problem in their own installations the order group for Goblin Deities is 17
Dervish is offline   #215 Reply With Quote
KingBarthur
Junior Member
 
Join Date: Aug 2016
Posts: 3

Old August 7th, 2016, 08:00 PM
Not sure what I'm doing wrong but I've downloaded the Community Pack, updated and still don't see any backgrounds other than Acolyte.

Using this URL:
http://www.shadowsoftware.net/herolab/5e/updates.xml

Is there something I'm doing wrong?
KingBarthur is offline   #216 Reply With Quote
Dervish
Senior Member
 
Join Date: May 2013
Location: Grand Forks ND
Posts: 128

Old August 10th, 2016, 09:48 AM
It's in character options you need to set all the defaults to activate the community service pack I will send screenshots later tonight
Dervish is offline   #217 Reply With Quote
ShadowChemosh
Senior Member
Volunteer Data File Contributor
 
Join Date: Jan 2010
Location: Chicago, IL (USA)
Posts: 10,700

Old August 10th, 2016, 10:05 AM
Quote:
Originally Posted by KingBarthur View Post
Not sure what I'm doing wrong but I've downloaded the Community Pack, updated and still don't see any backgrounds other than Acolyte.

Using this URL:
http://www.shadowsoftware.net/herolab/5e/updates.xml

Is there something I'm doing wrong?
See THIS post for help.

Hero Lab Resources:
Pathfinder - d20pfsrd and Pathfinder Pack Setup
3.5 D&D (d20) - Community Server Setup
5E D&D - Community Server Setup
Hero Lab Help - Hero Lab FAQ, Editor Tutorials and Videos, Editor & Scripting Resources.
Created by the community for the community
- Realm Works kickstarter backer (Alpha Wolf) and Beta tester.
- d20 HL package volunteer editor.
ShadowChemosh is online now   #218 Reply With Quote
Jiriki13
Junior Member
 
Join Date: Jan 2008
Location: South Bend, IN
Posts: 9

Old August 10th, 2016, 07:41 PM
I'm trying to create a warlock in 5e and it doesn't show the spell Witch Bolt in the spell list for my warlock. I went into create the spell myself and noticed that it is in there, just not showing up for a warlock. I also tried to create a sorcerer and it's not there for that class either and should be.

How can I fix this?

PS I wasn't sure where to post this question.
Jiriki13 is offline   #219 Reply With Quote
daplunk
Senior Member
 
Join Date: Jan 2016
Location: Adelaide, Australia
Posts: 2,227

Old August 10th, 2016, 07:51 PM
Witch Bolt is enabled for Sorcerer, Warlock and Wizard. I just tested and can add it to them all.

Are you certain you have the community pack enabled? How many backgrounds do you see?
daplunk is online now   #220 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:28 PM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.