Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - Pathfinder Roleplaying Game

Notices

Reply
 
Thread Tools Display Modes
blenman
Junior Member
 
Join Date: Sep 2017
Posts: 8

Old June 9th, 2019, 01:17 PM
Hi, I'm getting this error when I load up Pathfinder and I think the 'fcSoPPX....' are Spheres of Power "Thing[s]." I'm not sure how to fix this? I have reinstalled everything and the versions are all current.

Quote:
The data files could not be loaded due to errors. Hero Lab will now attempt to load them in recovery mode. Once loaded, you can access the editor as normal to correct any errors.

The following errors occurred:

Syntax error in 'eval' script for Thing 'fcSoPXGbSW' (Eval Script '#1') on line 6
-> Non-existent field 'DC' used by script
Syntax error in 'eval' script for Thing 'fcSoPXGnIn' (Eval Script '#1') on line 8
-> Non-existent field 'DC' used by script
Syntax error in 'eval' script for Thing 'fcSoPXGnSy' (Eval Script '#1') on line 8
-> Non-existent field 'DC' used by script
FWIW, the above issue is just loading Pathfinder. If I load my character that has been using SoP for a while now, I get the following mess and my character is missing everything (including spheres tabs). I figured I would try to fix the Pathfinder loading issue first...

Quote:
Errors were encountered when loading the saved portfolio! If you notice incorrect behaviors in your portfolio, please report it to the data file authors (you can contact them from the Help menu).

Critical information not found in data files: Source 'RGG - Adventurer's Handbook: Volume 1'
Critical information not found in data files: Source 'RGG - Krazy Kragnar's Black Market Magic Items'
Critical information not found in data files: Source 'RGG - Krazy Kragnar's Magic Staff Emporium'
Critical information not found in data files: Source 'RGG - Phosonith the Cruel Charmer'
Critical information not found in data files: Source 'S2P - Forgotten Foes'
Critical information not found in data files: Source 'C7E - Tome of Secrets'
Critical information not found in data files: Source 'LG - Treasury of the Macabre'
Critical information not found in data files: Source 'GR - Jade Dragons & Hungry Ghosts'
Critical information not found in data files: Source 'Spheres of Power'
Critical information not found in data files: Source 'Spheres of Power: Expanded Options'
Critical information not found in data files: Source 'Way of the Wicked AP'
Critical information not found in data files: Source 'Academy of Secrets'
Critical information not found in data files: Source 'GR - Advanced Bestiary'
Critical information not found in data files: Source 'GR - Advanced Race Codex'
Critical information not found in data files: Source 'Blood of Dragonscar'
Critical information not found in data files: Source 'Beyond the Vault of Souls'
Critical information not found in data files: Source 'GR - Book of Fiends'
Critical information not found in data files: Source 'Broken Chains'
Critical information not found in data files: Source 'Carrion Hill'
Critical information not found in data files: Source 'Carnival of Tears'
Critical information not found in data files: Source 'City of Golden Death'
Critical information not found in data files: Source 'Clash of the Kingslayers'
Critical information not found in data files: Source 'Conquest of Bloodsworn Vale'
Critical information not found in data files: Source 'Crown of the Kobold King'
Critical information not found in data files: Source 'Crucible of Chaos'
Critical information not found in data files: Source 'Crypt of the Everflame'
Critical information not found in data files: Source 'Curse of the Riven Sky'
Critical information not found in data files: Source 'Cult of the Ebon Destroyer'
Critical information not found in data files: Source 'Doom Comes to Dustpawn'
Critical information not found in data files: Source 'Dawn of the Scarlet Sun'
Critical information not found in data files: Source 'FGG - Dead Man's Chest (d20)'
Critical information not found in data files: Source 'The Demon Within'
Critical information not found in data files: Source 'Doom Comes to Dustpawn'
Critical information not found in data files: Source 'The Dragon's Demand'
Critical information not found in data files: Source 'The Emerald Spire Superdungeon'
Critical information not found in data files: Source 'Entombed with the Pharaohs'
Critical information not found in data files: Source 'Faiths of Eberron'
Critical information not found in data files: Source 'Fangwood Keep'
Critical information not found in data files: Source 'The Feast of Ravenmoor'
Critical information not found in data files: Source 'Flight of the Red Raven'
Critical information not found in data files: Source 'From Shore to Sea'
Critical information not found in data files: Source 'GGP - Race: Lagos'
Critical information not found in data files: Source 'GGP - Race: Scyleen'
Critical information not found in data files: Source 'Gallery of Evil'
Critical information not found in data files: Source 'The Godsmouth Heresy'
Critical information not found in data files: Source 'Guardians of Dragonfall'
Critical information not found in data files: Source 'Hangman's Noose'
Critical information not found in data files: Source 'Into the Haunted Forest'
Critical information not found in data files: Source 'The Harrowing'
Critical information not found in data files: Source 'Hungry are the Dead'
blenman is offline   #721 Reply With Quote
TheIronGolem
Senior Member
 
Join Date: Feb 2015
Posts: 551

Old June 9th, 2019, 01:31 PM
Hi blenman,

Your errors are from an outdated version of Expanded Options. For some reason (which is probably my fault), HL isn't auto-detecting that there's a newer version of Expanded Options, which causes it to get left behind when the rest of SoP and or SoM gets updated. If you update Expanded Options you should be okay.
TheIronGolem is offline   #722 Reply With Quote
blenman
Junior Member
 
Join Date: Sep 2017
Posts: 8

Old June 9th, 2019, 02:06 PM
It shows as 1.7 under Manage Third-Party Updates:



I'm not sure what version I should have?

Edit: The "Latest Patch Notes" are at 1.6, but I see the "Current Package Available" version says 1.7

Last edited by blenman; June 9th, 2019 at 02:09 PM.
blenman is offline   #723 Reply With Quote
TheIronGolem
Senior Member
 
Join Date: Feb 2015
Posts: 551

Old June 9th, 2019, 02:09 PM
I see you also have a 1.0 version of Expanded Options listed there at the top? That's odd. I would definitely remove that and see if the problem persists. If it does, try re-downloading 1.7.
TheIronGolem is offline   #724 Reply With Quote
blenman
Junior Member
 
Join Date: Sep 2017
Posts: 8

Old June 9th, 2019, 02:10 PM
I just noticed it says 1.0 at the top... let me try removing that...
blenman is offline   #725 Reply With Quote
blenman
Junior Member
 
Join Date: Sep 2017
Posts: 8

Old June 9th, 2019, 02:13 PM
Ok, that fixed the loading issue and some of the portfolio loading issues (strangely), but the following source issues still exist:

Quote:
Errors were encountered when loading the saved portfolio! If you notice incorrect behaviors in your portfolio, please report it to the data file authors (you can contact them from the Help menu).

Critical information not found in data files: Source 'Spheres of Power: Expanded Options'
Critical information not found in data files: Source 'Spheres of Power: Expanded Options'
Critical information not found in data files: Source 'Spheres of Power: Expanded Options'
Critical information not found in data files: Source 'Spheres of Power: Expanded Options'
Critical information not found in data files: Source 'Shapeshifter's Handbook'
Critical information not found in data files: Source 'Destroyer's Handbook'
Critical information not found in data files: Source 'Mentalist's Handbook'
Critical information not found in data files: Source 'Telekinetic's Handbook'
blenman is offline   #726 Reply With Quote
TheIronGolem
Senior Member
 
Join Date: Feb 2015
Posts: 551

Old June 9th, 2019, 03:07 PM
Your "Manage Third-Party Updates" menu did not make mention of any of those other sphere handbooks, so if your portfolio relies on information from those sources I would not be surprised to see those errors. If you have those packages I would go ahead and reinstall them. But instead of installing straight from a .hl file I would recommend you use the update process (detailed in the readme for each package) to grab the latest versions, otherwise you're likely to be in for another mess of errors from outdated files.
TheIronGolem is offline   #727 Reply With Quote
blenman
Junior Member
 
Join Date: Sep 2017
Posts: 8

Old June 9th, 2019, 03:41 PM
I reinstalled those and added the sources to get updates. That did the trick! Thanks!
blenman is offline   #728 Reply With Quote
Ualaa
Senior Member
 
Join Date: Sep 2013
Location: Vancouver, Canada.
Posts: 549

Old June 9th, 2019, 08:02 PM
I get excited for new Sphere options, anytime I see activity in this thread.
Soon...
Ualaa is online now   #729 Reply With Quote
GreyLurker
Junior Member
 
Join Date: Apr 2015
Posts: 26

Old June 19th, 2019, 01:41 PM
Is there any way to print an Armiger's custome weapons and what spheres are linked to them?
GreyLurker is offline   #730 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:47 AM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.