Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Army Builder Forums > Army Builder

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
prozinskij at yahoo.com
Guest
 
Posts: n/a

Old August 1st, 2000, 07:06 AM
Hello,
I tried to post this yesterday, but I don't think it worked. I
appologize if it is posted a second time.

I'm trying to build a data file. I'm using the 'rang' and 'must'
attributes to get the spin buttons for multiple weapon selection on a
unit and for roster validation.

The 'rang 'attribute seems to be working fine as I get the spin
button. When I add the 'must' attribute it doesn't seem to recognize
the category of the option.

I have an assault rifle assigned to the Ranged category. I can
have between 2 and 8 of them in a squad, depending on the squad's
size and number of special weapons. With the default being 4 for
minimum squad size. So I have the 'rang' attribute set to 'rang:2-8-
start@4'. That seems to be working.

I want the validation rules to notify the user when there aren't
enough or there are too many weapons assigned to the squad. I use
the 'must:categ=Ranged+Special+Heavy@min=#'
and 'must:categ=Ranged+Special+Heavy@max=#' attributes. When I load
the data file and select the unit I get a validation error no matter
how many weapons I assign the unit. The error is "Not enough options
of category 'Ranged+Special+Heavy' are assigned to unit 'Standard
Infantry Squad' (min unit size)." It doesn't matter what combination
of categories I check for I get the validation error.

I'm using version 1.4d of AB and the Construction Kit. I've tried
deleteing the definition file and recompiling it, rebuilding the
datafiles and stripping them down to just the unit and the options.
Everything I could think of. I've tried looking at some of the other
datafiles for other games and see how they've implemented it. I tried
duplicating the way it was done in other files and have them set up
nearly identical, except for different names for all the units and
options. No luck. I don't see what it is that I'm missing. Can anyone
shed some light on this?

Thanks in advance.

-Joe



--------------------------------------------------------------------<e|-
Go to Maingate.com to improve the quality of military life.
http://click.egroups.com/1/7637/4/_/36190/_/965142404/
--------------------------------------------------------------------|e>-

To unsubscribe from this group, email

armybuilder-unsubscribe@egroups.com
  #1 Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spellcasting attribute Enarion HL - d20 System 10 April 6th, 2007 06:50 PM
Problem with the "take" attribute fusilier at kc.rr.com Army Builder 8 July 22nd, 2004 11:31 AM
Info Attribute pete at wargamesdirectory Army Builder 3 November 27th, 2002 03:12 AM
"over:" attribute mobo at adelphia.net Army Builder 1 June 7th, 2002 09:51 AM
Range attribute questions mobo at adelphia.net Army Builder 0 May 25th, 2002 12:31 PM


All times are GMT -8. The time now is 06:23 PM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.