Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > Hero Lab Discussion

Notices

Reply
 
Thread Tools Display Modes
mirtos
Senior Member
 
Join Date: Oct 2011
Posts: 865

Old March 27th, 2012, 09:23 AM
I recently posted about a mount thing, but it turned out what had happened is that some of my settings got reset in an update. Restrict companion race causes a problem in the d20 universe when you purchase an animal.

Last edited by mirtos; March 27th, 2012 at 02:29 PM.
mirtos is offline   #181 Reply With Quote
Colen
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2008
Posts: 4,728

Old March 27th, 2012, 02:55 PM
Quote:
Originally Posted by buzzby View Post
I posted this in the bug reports, but that may have been the wrong area.

Since the recent update I've been unable to open my main portfolio. I've also tried importing the characters into a new portfolio. Both crash Herolab.

Not sure what I need to be posting to help troubleshoot.

Cheers!
buzzby, please email me with the crash report at colen@wolflair.com - loading saved portfolios seems to be working for everyone else, so it's hard to identify the problem unless you can get us the crash report.
Colen is offline   #182 Reply With Quote
Colen
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2008
Posts: 4,728

Old March 27th, 2012, 02:56 PM
Quote:
Originally Posted by mirtos View Post
Im not sure if this is a mac bug or a general bug. I usually create class variants, but this time I created a class, using copy. This was done in d20. This was done to create a bad that isnt alignment restricted. All I did was copy the class, remove the alignment restricted, and give them another skill appropriate to my campaign.

It all seemed to work fine. But when I create the character, and select this different class, and click on the class tab, i clicked under special abilities, and it was listed blank for all levels. When i print, it doesnt list them either. But when i go back to my class in the editor, they are clearly there.

I can mail my editted files if needed. If anyone has any thoughts on what i might be doing wrong, let me know.
Please email me at colen@wolflair.com with the edited files and I'll take a look.
Colen is offline   #183 Reply With Quote
mirtos
Senior Member
 
Join Date: Oct 2011
Posts: 865

Old March 27th, 2012, 03:24 PM
Colen, I will do so. But i just discovered another bug related to variant classes. I can reproduce it every time.

Whenever i edit a variant class, the override dropdowns for the saves dont really seem to work. If I select something other than none, (good/med/poor) and select it, it doesnt show it as one of the three, but alsways show as 'none'. (even though i think one of them is actually poor and its not supposed to be), and when i click it enough times, i get a crash. I was able to reproduce this three or 4 times tonight.

Here is the beginning of the stacktrace.


rocess: Hero Lab [13537]
Path: /Applications/Hero Lab.app/Contents/MacOS/Hero Lab
Identifier: com.LWDTechnology.Hero Lab
Version: 3.9.4 (3.9.4.290)
Code Type: X86 (Native)
Parent Process: launchd [169]

Date/Time: 2012-03-27 19:21:27.077 -0400
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 1014530 sec
Crashes Since Last Report: 3
Per-App Interval Since Last Report: 55905 sec
Per-App Crashes Since Last Report: 3
Anonymous UUID: 82735BE3-58C0-44A5-AEB6-39551172547E

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Application Specific Information:
objc_msgSend() selector name: view


Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x90157f8b objc_msgSend + 27
1 com.apple.AppKit 0x905fb31f -[NSApplication sendEvent:] + 5683
2 com.apple.AppKit 0x9058f253 -[NSApplication run] + 917
3 com.LWDTechnology.Hero Lab 0x0025c317 C_Canvas_Base::~C_Canvas_Base() + 4375
4 com.LWDTechnology.Hero Lab 0x0025cd68 C_Canvas_Base::~C_Canvas_Base() + 7016
5 com.LWDTechnology.Hero Lab 0x0025d7a4 C_Canvas_Base::~C_Canvas_Base() + 9636
6 com.LWDTechnology.Hero Lab 0x0025dad3 C_Application_Entry::Entry(int, char**) + 339
7 com.LWDTechnology.Hero Lab 0x0025d85b C_Canvas_Base::~C_Canvas_Base() + 9819
8 com.LWDTechnology.Hero Lab 0x00002ba5 0x1000 + 7077

Last edited by mirtos; March 27th, 2012 at 03:39 PM.
mirtos is offline   #184 Reply With Quote
Goneril
Junior Member
 
Join Date: Jan 2012
Posts: 7

Old March 27th, 2012, 06:27 PM
Quote:
Originally Posted by Colen View Post
buzzby, please email me with the crash report at colen@wolflair.com - loading saved portfolios seems to be working for everyone else, so it's hard to identify the problem unless you can get us the crash report.
Colen,

I'm having the same issue with saved portfolios crashing. I just e-mailed you two crash logs, one from opening Hero Lab then the portfolio, the other from telling Recent Documents to open the portfolio.
Goneril is offline   #185 Reply With Quote
egg_green
Senior Member
 
Join Date: Aug 2007
Posts: 103

Old March 28th, 2012, 03:37 AM
Last night I had an issue with a tooltip getting "stuck". The tooltip would not go away, even if I clicked on it or something else. Hero Lab itself was completely unresponsive; I could not switch tabs or anything. Hovering/clicking on icons that should have had other tooltips did not help.

This happened after I was using LogMeIn to try accessing Hero Lab from my Mac through LogMeIn on my iPad. I think the issue may have been related to changing screen resolution while the tooltip was showing. I will try to reproduce it later today.

Thanks!
egg_green is offline   #186 Reply With Quote
burner2501
Junior Member
 
Join Date: Apr 2008
Posts: 13

Old March 29th, 2012, 05:32 AM
Because I don't see it in the thread here I thought I'd post this.

I just snagged the latest update through the updater utility inside the HL app on my MacBook Pro. I did this update just as I did the last. It worked then but it's not working this time. I get the following error when I try and start the HL app.

Unable to locate file: hl.xml

Thanks.

Victor
burner2501 is offline   #187 Reply With Quote
TehBagder
Senior Member
 
Join Date: Dec 2011
Posts: 100

Old March 30th, 2012, 07:47 PM
A possible solution to crash reports on opening older portfolio files. If you have a custom editor file you've used, open up a blank portfolio. Then open up the editor and open up the file. Choose one of the items in it and test it. Close the editor, and reboot Hero Lab. It should load the portfolio next time round. No idea why this works, but I found it out after having a portfolio constantly crash for me.
TehBagder is offline   #188 Reply With Quote
Enderrin
Junior Member
 
Join Date: Mar 2012
Posts: 4

Old April 1st, 2012, 12:24 PM
Quote:
Originally Posted by egg_green View Post
Unfortunately, this is not a Mac bug. The Statblock output has always truncated the text of longer descriptions.
If this is the case, and Lone Wolf has never fixed it, can anyone with experience creating custom outputs tell me if this is something that "Could" be fixed by creating a custom output stat block?
Enderrin is offline   #189 Reply With Quote
Colen
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2008
Posts: 4,728

Old April 2nd, 2012, 09:00 AM
The "crash when loading portfolio" issue should be resolved in the beta we released on Friday.

Burner2501, I think I emailed you this - in case that wasn't you: It sounds like your update didn't work properly for some reason. Go through the beta application process here:

http://wolflair.com/hero_lab_mac_beta.php

And you should get the latest installer - download and install it and you should be good to go.
Colen is offline   #190 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:44 AM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.