Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
Exmortis
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 766

Old April 26th, 2017, 07:03 AM
First,

The export/import issue I had submitted as a bug, is solved and I was able to export and import the realm in question. Great stuff!! Thanks!

What is really weird, is what the update did to every single one of my realms:

Many of my custom tag domains had its tags duplicated. Seemingly in every single realm (have not opened all yet, but so far with out exception) has had one of more of its tag domains tags duplicated, perfectly, and in its entirety.

So example of the error:

Domain 'Community Type': Tag 'Encampment'
Domain 'Community Type': Tag 'Fortification'
Domain 'Community Type': Tag 'Other'
Domain 'Community Type': Tag 'Outpost'
Domain 'Community Type': Tag 'Racial City'
Domain 'Community Type': Tag 'Settlement'

So now I have to go in and delete the entry, what is even weirder, that I have now topics using both the old and new tag, yet there was just one when I created them. I have set structure I apply to a new realm when I create it.

Nothing is broken, but it is a fair amount of tedious work to go back through and delete al the duplicate tags in every realm.

This only happens on my tag domains I created.

Exmortis aka "Scott"
RW - Needs Rez spell
HL - Game Master/Designer
RPG Tools - Campaign Cartographer 3+, D20 Pro Ultimate
Real Life - IT Security
Hobby - Anything on water or ATV
Exmortis is offline   #1 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 26th, 2017, 08:16 AM
I had the samething happen a couple of updates ago when they came out with alignment tags and I had created one prior.
ruhar is offline   #2 Reply With Quote
Exmortis
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 766

Old April 26th, 2017, 11:02 AM
Yeah with further work it is not every realm, but near half. which is odd in itself, but cool enough.

It is a mixture of my custom tags and default tags.

I have gone thru half my realms, and fixed it all. Also used this to run the link fix up and fix all the little issues as well, so all in all a good exercise lol.

But I am really happy my export/import issue was solved!

Exmortis aka "Scott"
RW - Needs Rez spell
HL - Game Master/Designer
RPG Tools - Campaign Cartographer 3+, D20 Pro Ultimate
Real Life - IT Security
Hobby - Anything on water or ATV
Exmortis is offline   #3 Reply With Quote
SteveT
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2016
Posts: 379

Old April 26th, 2017, 04:13 PM
@Exmortis

For several older versions of Realm Works, importing would in certain cases create duplicate tags in your realm. However, in those older versions of Realm Works, duplicate tags were perfectly legal, so Realm Works wouldn't warn you about this.

Things have changed in the latest version of Realm Works (build 240). Duplicate tags are no longer allowed, and importing no longer creates duplicate tags (or at least it shouldn't).

Based on what you've said here, it sounds like perhaps you did some imports with previous versions of Realm Works where duplicate tags were created, but perhaps you weren't aware that the duplicates were created because Realm Works didn't flag this to your attention. Now that you've upgraded to the latest version, they are being flagged to your attention. Does that sound accurate? Or does something else appear to be going on?

More generally, has anyone reading this thread experienced any cases where the latest version of Realm Works (build 240) creates duplicate tags on import into a realm that previously had no duplicate tags? If so, that is a bug, since import should no longer be creating duplicate tags, so please let us know
SteveT is offline   #4 Reply With Quote
ruhar
Senior Member
 
Join Date: Nov 2011
Location: Langley, WA, USA
Posts: 602

Old April 26th, 2017, 08:00 PM
For me it wasn't anything I imported, it was a realm I had been working on for a few years. I started it before RW had alignment tags so I created my own alignment tags. When RW added alignment tags the two didn't play well with each other. I did report the bug and it was eventually fixed in one of the updates.
ruhar is offline   #5 Reply With Quote
Exmortis
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 766

Old April 27th, 2017, 05:18 AM
@SteveT

You are right in some cases, I did do some imports. How ever it has happened to realms that have never seen an import.

However it is not as wide spread as I first thought and prompted a clean up.

Again, if that's the payment for my import/export solution? worth it.

Exmortis aka "Scott"
RW - Needs Rez spell
HL - Game Master/Designer
RPG Tools - Campaign Cartographer 3+, D20 Pro Ultimate
Real Life - IT Security
Hobby - Anything on water or ATV
Exmortis is offline   #6 Reply With Quote
SteveT
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2016
Posts: 379

Old May 1st, 2017, 06:39 PM
Another possibility might be game system conversion... like import, game system conversion would in some cases create duplicate tags in older versions of Realm Works, but no longer does that in the most recent version.

For the realms that you didn't import anything into but still got duplicate tags, did you run game system conversion on them at some point in the past?
SteveT is offline   #7 Reply With Quote
Exmortis
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 766

Old May 3rd, 2017, 08:49 AM
Conversation is probably the key, I converted all realms away from legacy.

Exmortis aka "Scott"
RW - Needs Rez spell
HL - Game Master/Designer
RPG Tools - Campaign Cartographer 3+, D20 Pro Ultimate
Real Life - IT Security
Hobby - Anything on water or ATV
Exmortis is offline   #8 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 06:02 PM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.