Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > Hero Lab Discussion

Notices

Reply
 
Thread Tools Display Modes
DaveM
Member
Lone Wolf Staff
 
Join Date: May 2018
Posts: 32

Old June 11th, 2019, 09:09 AM
We are releasing a beta version of Hero Lab for the Mac today that is 64-bit and thus compatible with the new macOS Catalina (10.15) (which is itself currently in beta).

This beta may be installed safely on top of existing 32-bit versions, allowing either version to be used at any time. The gamesystems will automatically re-compile when switching versions, but otherwise they should be able to share data seamlessly.

If problems are discovered in the Beta, you may always revert to the original application. Any issues with the Beta, please report to our support email or in this forum.

[EDIT] Updated beta is now at:

https://www.wolflair.com/download/pl...64_install.dmg

Last edited by DaveM; July 3rd, 2019 at 08:40 AM.
DaveM is offline   #1 Reply With Quote
Tekwych
Senior Member
 
Join Date: Aug 2013
Location: New Mexico
Posts: 161

Old June 11th, 2019, 04:05 PM
Thanks Dave. something to download when I get home tonight.
Tekwych is online now   #2 Reply With Quote
hart8210
Junior Member
 
Join Date: Feb 2017
Posts: 8

Old June 14th, 2019, 02:12 PM
I installed the beta today. It installed fine and asked to reinitialize my license key, which it did without a problem. After restarting Hero Lab the problem is that it says my game system is not licensed for this license (Pathfinder in my case). I reactivated the license again from the program itself, but upon restart still get the same issue with the game system running in demo mode. Any ideas?
hart8210 is offline   #3 Reply With Quote
Tekwych
Senior Member
 
Join Date: Aug 2013
Location: New Mexico
Posts: 161

Old June 14th, 2019, 10:07 PM
I’ve been able to open Pathfinder, Shadowrun (4&5), and Savage Worlds without problem. I’ve made new character but have not saved yet.
Tekwych is online now   #4 Reply With Quote
DaveM
Member
Lone Wolf Staff
 
Join Date: May 2018
Posts: 32

Old June 17th, 2019, 08:39 AM
Quote:
Originally Posted by hart8210 View Post
I installed the beta today. It installed fine and asked to reinitialize my license key, which it did without a problem. After restarting Hero Lab the problem is that it says my game system is not licensed for this license (Pathfinder in my case). I reactivated the license again from the program itself, but upon restart still get the same issue with the game system running in demo mode. Any ideas?
Which version of macOS are you working with? I have had at least one other person report this same issue who is using 10.15 beta, but I am unable to reproduce it in 10.13 or 10.14.
DaveM is offline   #5 Reply With Quote
jensfischerhh
Junior Member
 
Join Date: Jun 2019
Posts: 1

Old June 17th, 2019, 11:01 AM
Quote:
Originally Posted by DaveM View Post
Which version of macOS are you working with? I have had at least one other person report this same issue who is using 10.15 beta, but I am unable to reproduce it in 10.13 or 10.14.
Same problem here, running on 10.13.6 High Sierra
jensfischerhh is offline   #6 Reply With Quote
hart8210
Junior Member
 
Join Date: Feb 2017
Posts: 8

Old June 20th, 2019, 08:21 AM
I am running Mojave, 10.14.
hart8210 is offline   #7 Reply With Quote
Tekwych
Senior Member
 
Join Date: Aug 2013
Location: New Mexico
Posts: 161

Old June 20th, 2019, 08:58 AM
I am at 10.14.5 (18F132) on a MacBook Pro
Tekwych is online now   #8 Reply With Quote
richwilkes
Junior Member
 
Join Date: Jun 2019
Posts: 1

Old June 20th, 2019, 04:25 PM
I'm seeing the same "unlicensed" problem as well. Running macOS 10.14.5. Specifically, it is telling me I'm not licensed for the Pathfinder content I've purchased.
richwilkes is offline   #9 Reply With Quote
DaveM
Member
Lone Wolf Staff
 
Join Date: May 2018
Posts: 32

Old July 2nd, 2019, 04:23 PM
I have posted an update to the Mac 64-bit beta that should address the issue with licenses not working. The installer for this is at:

https://www.wolflair.com/download/pl...64_install.dmg

Thanks to everyone who has tried this out so far!
DaveM is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 10:48 AM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.