Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Feature Requests

Notices

Reply
 
Thread Tools Display Modes
mhwittek
Junior Member
 
Join Date: Sep 2014
Location: Meridian, Idaho
Posts: 22

Old January 26th, 2016, 11:22 AM
Hello Liz,
I know this not technically a feature, but in light of the commercial content launching for Realm Work in Q1 of this year, I am asking via this official channel to add the TRAVELLER adventures all version especially T5 to the line up. Since some adventures are over thirty years old, you may get them in public domain.

I can not wait to see what you all come up with for your content market.


Cordially,
Mike W.
mhwittek is offline   #1 Reply With Quote
MaxSupernova
Senior Member
 
Join Date: Mar 2014
Posts: 411

Old January 26th, 2016, 12:48 PM
Seconded!

Though the new version of Traveller was just released this month, and it's incompatible. :-\
MaxSupernova is offline   #2 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,687

Old January 26th, 2016, 12:51 PM
You're probably better served petitioning Mongoose or whoever is publishing Traveler now.
kbs666 is offline   #3 Reply With Quote
Silveras
Senior Member
 
Join Date: Aug 2010
Posts: 1,521

Old January 26th, 2016, 02:43 PM
I believe there are two separate versions of Traveller now.

Far Future Entertainment (if I recall the name correctly) has Traveller 5.

Mongoose has Traveller 2300 (and other properties ?)

I don't know that either is published under an Open License of any kind.. so any project would have to begin with the publishers.
Silveras is offline   #4 Reply With Quote
mhwittek
Junior Member
 
Join Date: Sep 2014
Location: Meridian, Idaho
Posts: 22

Old January 26th, 2016, 08:41 PM
Quote:
Originally Posted by MaxSupernova View Post
Seconded!

Though the new version of Traveller was just released this month, and it's incompatible. :-\
MaxSupernova,
There is no such thing as incompatible with Realm Works. Lets say I am playing TRAVELLER 5th edition, and some commercial content comes out for let say Mongoose Traveller 2nd edition, since Realm Works really focus on the story and not the mechanics, any content that I may purchase like the Clement Sector, and I just make what changes that are necessary afar as the GM notes that are relevant for the TRAVELLER 5 mechanics and modifiers, and now I have just added an adventure from another game system in my TRAVELLER 5 universe. And visa verse with other versions of TRAVELLER. You name your flavor. By the way, I have been doing that with a Pathfinder game that I am running. Pathfinder mechanics, but I am using a D&D 3.0 adventure called Return to the Temple of Elemental Evil in the Greyhawk campaign world setting. You might have heard of it?

Liz's Spotlights Series have been very informative.

Cordially,
Mike W.
mhwittek is offline   #5 Reply With Quote
mhwittek
Junior Member
 
Join Date: Sep 2014
Location: Meridian, Idaho
Posts: 22

Old January 26th, 2016, 08:56 PM
Quote:
Originally Posted by kbs666 View Post
You're probably better served petitioning Mongoose or whoever is publishing Traveler now.
Kbs666,
Do them all since there are so many version, that mean tons of source material to be picked up. Thou, I like TRAVELLER 5 and have nothing against Mongoose Traveller, and I am thinking of purchasing the new edition of Mongoose Traveller in PDF format. I think it would be totally awesome sauce just to be able to expand my choices in gaming adventures with our the concern of mechanics getting in my way. As far as I see it, produce all the adventure, past, present, and future of all the different edition of TRAVELLER in Realm Works content market. The let me choose as a GM what I want in my universe.


Most Cordially,
Mike W.
mhwittek is offline   #6 Reply With Quote
Silveras
Senior Member
 
Join Date: Aug 2010
Posts: 1,521

Old January 27th, 2016, 05:47 AM
@mhwittek: The point we are making is that LoneWolf cannot unilaterally decide to just provide content for Traveller.. any version of it. That applies to both RealmWorks and HeroLab, but more strongly to RealmWorks.

Traveller is not published under any open license, at least that i know of. That means the mechanics are not available to create HeroLab support for it.

Even if the mechanics were, the story content.. the setting places, history, events, etc., would likely not be covered under that license.

In both cases, LoneWolf would first need to negotiate a license with the publisher. Since there are multiple separate versions of Traveller being published by different companies, that would be a separate license for each.

What kbs666 is suggesting is that you have more chance to see some of this happen by writing to the various publishers and suggesting to them that they participate.
Silveras is offline   #7 Reply With Quote
MaxSupernova
Senior Member
 
Join Date: Mar 2014
Posts: 411

Old January 27th, 2016, 09:57 AM
Quote:
Originally Posted by mhwittek View Post
Lets say I am playing TRAVELLER 5th edition, and some commercial content comes out for let say Mongoose Traveller 2nd edition, [...] and I just make what changes that are necessary afar as the GM notes that are relevant for the TRAVELLER 5 mechanics and modifier
I don't see how this is different than what we've done with version differences for decades now. It doesn't mean "There's no such thing as incompatible", it means "It's still incompatible, but you can store the changes that you have to make to make it compatible in Realm Works instead of whatever else you used to use."

This, however happens to have nothing to do with the point of the thread.

Last edited by MaxSupernova; January 27th, 2016 at 10:17 AM.
MaxSupernova is offline   #8 Reply With Quote
the_redbeard
Member
 
Join Date: Aug 2015
Location: Seattle, WA
Posts: 89

Old January 27th, 2016, 03:37 PM
Quote:
Originally Posted by Silveras View Post

Traveller is not published under any open license, at least that i know of.

Mongoose Traveller is published with the OGL
. They've just released a new version, and I'm not sure how that relates to Mongoose Traveller 1.0.

Obviously, this is not Traveller 5. And my impression is that the Third Imperium Setting would be product identity and not covered in the OGL.

However, the mechanics of Mongoose Traveller 1.0 (which are a cleaned up, unified version of Classic Traveller) are very much open. This includes careers, skills, and even equipment.
the_redbeard is offline   #9 Reply With Quote
Silveras
Senior Member
 
Join Date: Aug 2010
Posts: 1,521

Old January 27th, 2016, 06:35 PM
Quote:
Originally Posted by the_redbeard View Post

Mongoose Traveller is published with the OGL
. They've just released a new version, and I'm not sure how that relates to Mongoose Traveller 1.0.

Obviously, this is not Traveller 5. And my impression is that the Third Imperium Setting would be product identity and not covered in the OGL.

However, the mechanics of Mongoose Traveller 1.0 (which are a cleaned up, unified version of Classic Traveller) are very much open. This includes careers, skills, and even equipment.
That's a start for HeroLab, then.
Silveras is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:16 AM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.