Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
joe2chillo
Member
 
Join Date: Mar 2018
Posts: 45

Old May 13th, 2019, 08:39 PM
Has anyone experienced an issue when syncing RW where the sync take a VERY long time? Currently I am syncing a rather small Realm and it takes somewhere in the neighborhood of 5-6 hours for it to sync from the server to my laptop. During this time, the disc usage on my laptop get very very high. The laptop is not old and is generally very fast. Surface Pro i7-7600U 2.5 GHZ, 16 GB RAM, and a 500GB SSD.

I have no issues on my desktop but when I try to sync down to the laptop it takes forever. Going into task manger shows the disk usage bouncing between 70% and 95% for the RW application.
No idea what is going on. Memory and CPU usage seem fine.
I have a ticket open with support but after some initial contact with them last month they have not responded. Hoping someone here can help. Thanks!
joe2chillo is offline   #1 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,538

Old May 14th, 2019, 03:26 AM
People have periodically reported a similar issue.

Can you plug your laptop into a wired ethernet connection? If you can try that and see if it improves syncing. If not go to a Starbucks or somewhere and see if a different WiFi connection has an effect.

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is online now   #2 Reply With Quote
joe2chillo
Member
 
Join Date: Mar 2018
Posts: 45

Old May 14th, 2019, 04:03 AM
Quote:
Originally Posted by kbs666 View Post
People have periodically reported a similar issue.

Can you plug your laptop into a wired ethernet connection? If you can try that and see if it improves syncing. If not go to a Starbucks or somewhere and see if a different WiFi connection has an effect.
Sorry. Should have mentioned that this is on a wired connection. Ethernet activity seems light as well.
[IMG][/IMG]

Last edited by joe2chillo; May 14th, 2019 at 04:12 AM.
joe2chillo is offline   #3 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,538

Old May 14th, 2019, 06:23 AM
Do you have another computer with RW on it you can test syncing with? It could be local to your machine or it could be an issue with your connection.

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is online now   #4 Reply With Quote
MNBlockHead
Senior Member
 
Join Date: Dec 2014
Location: Twin Cities Area, MN, USA
Posts: 1,293

Old May 14th, 2019, 06:23 PM
Is this a new realm with a lot of content, such as a lot of imported content from the content market?

I have several sizable realm and RW is pretty quick when synchronizing, but I sync regularly so it never has a great deal to update.

In the past when I had to resync a large realm from scratch, it can take a long time. Even on a decent connection. My .realm file is 2.7 GB large.

RW Project: Dungeons & Dragons 5th edition homebrew world
Other Tools: CampaignCartographer, Cityographer, Dungeonographer, Evernote
MNBlockHead is offline   #5 Reply With Quote
Grey Mage
Senior Member
 
Join Date: Feb 2011
Posts: 279

Old May 14th, 2019, 07:01 PM
I have noticed a couple of slow downs with syncing after importing lots of content... My realm is just under 6gb so there is a bit there.
Grey Mage is offline   #6 Reply With Quote
joe2chillo
Member
 
Join Date: Mar 2018
Posts: 45

Old May 15th, 2019, 06:50 AM
So I resolved the issue and wanted to share for future users who may experience the same issue. To answer a few questions some of you had as well,
I do have a 2nd computer that was not experiencing the issue and the issue was confined to my laptop. Though I thought it could be some setting or corruption tin the install of my laptop, though I did try reinstalling.
Also, the realm was newer and not very large. Even if it was a full sync it should only take a few minutes.

However, the issue was not with RW but with the laptop. As I mentioned I have a newer MS Surface Pro with some pretty good specs. However, it seems Microsoft skimped out on the SSDs a bit. Tons of users have reported similar issues on MS forums and other sites. A few fixes were offered such as installing the Samsung NVMe driver for the SSD instead of the MS driver. I was unable to do this however. What I ended up doing was disabling Write Cache Buffer Flushing. Soon as this was disabled the drive started working at a more reasonable level and realm works was able to sync in a few minutes. The drive still doesn't perform as fast as you would expect an SSD to but its good enough for what I am doing on this computer. If this was my gaming rig I'd probably be pissed.

So if anyone has a Microsoft Surface and is having an issue with slow syncs here is your fix!
joe2chillo is offline   #7 Reply With Quote
clithgow
Junior Member
 
Join Date: May 2018
Posts: 15

Old May 15th, 2019, 08:43 AM
Thanks for the follow up! I too use a Surface and while I'm not having any issues currently its nice to be armed with this info!
clithgow is offline   #8 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,538

Old May 15th, 2019, 10:18 AM
While its probably safe to do this on a tablet or laptop that has a battery please be aware this can cause serious disk corruption on a computer if that computer loses power.

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is online now   #9 Reply With Quote
weogarth
Senior Member
 
Join Date: Feb 2013
Posts: 299

Old May 21st, 2019, 10:35 AM
Thanks. Fortunately my Surface laptop has not shown this behavior (yet?). Glad you were able to figure it out.

Gary
Assistant Calendar Champion

GM: D&D 3.5 homegrown Local/Small Scale campaign
GMing blog: http://www.undiscoveredworlds.com
weogarth is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:42 AM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.