Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - d20 System

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Provos
Senior Member
 
Join Date: Mar 2011
Location: USA
Posts: 257

Old October 11th, 2020, 09:01 AM
Hey, I am trying to make a new material for weapons. I thought I had it figured out but now I am getting an error. The material adds +1 to hit and damage but that isn't a magical property or enhancement bonus. It should stack with everything. I took the code from another ablity and copied the phase and priority

Code:
 Phase Post-level (users) Priority 1100
container.parent.field[wDamBonus].value += 1
  container.parent.field[wAttBonus].value += 1
I got a bow of elvenkind that was custom made for my diety. I removed the eval script to only work for elves. I got that to work fine and the script for variable strength bonus works perfectly. Well the dm decided to add that new material to my bow and I keep getting an error when trying to combine them. Also after I do the material change for the bow the original material change seems to also get the same error now.

Code:
Phase Post-Attributes (Users) Priority 5000 Index 1
field[wMaxStr].value = hero.child[aSTR].field[aModBonus].value

Phase Post-level (users) Priority 1100 Index 2
container.parent.field[wDamBonus].value += 1
  container.parent.field[wAttBonus].value += 1
Attached Images
File Type: png error 2020-10-11 114608.png (147.8 KB, 3 views)
Provos is offline   #1 Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:24 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.