Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - D&D 5th Edition SRD

Notices

Reply
 
Thread Tools Display Modes
Hollis
Senior Member
Lone Wolf Staff
 
Join Date: Aug 2012
Posts: 700

Old April 15th, 2016, 10:33 AM
Version 1.4 of the 5th Edition SRD files is now available! This includes the remaining creatures from the SRD, custom monster creation, plus assorted other changes. Here's the full list:

Enhancements &amp Changes
  • Added the rest of the monsters from the SRD!
  • A "Custom Monster" race is now available, allowing you to build your own monsters!
  • Weapon, Armor, and Tool proficiencies are now shown on the Special tab.

Bug Fixes
  • On the iPad, the dice roller was not functioning correctly for ranged weapons, or for NPCs (it would always roll the average damage).
  • The cloak of displacement was causing a error when using the printed sheet.
  • The Warlock Pact of the Chain wasn't adding the extra familiar options.
  • Trinkets were missing from the editor.
  • Expertise wasn't displaying itself when applied to thieves's tools.

Data File Authoring
  • There was a typo in the spellcasting section for races in the editor.
  • The wTarget field has been extended.
Hollis is offline   #1 Reply With Quote
Mergon
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 747

Old April 15th, 2016, 02:43 PM
Still getting the following error messages if I have Enable Data File Debugging enabled:

Quote:
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 21
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 21
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
- - -
Invalid tag expression specified for string-based tag reference term
Location: Procedure 'xospells' near line 94
Once again, I removed my data files, the 5e Community files, and completely removed and re-installed HL Still get the errors.

Watch your back, Conserve your ammo,
and NEVER cut a deal with a dragon!
Mergon is offline   #2 Reply With Quote
Mergon
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 747

Old April 15th, 2016, 02:51 PM
The capability to select a subtype (fey, celestial, or fiend) for a familiar is still missing.

Watch your back, Conserve your ammo,
and NEVER cut a deal with a dragon!
Mergon is offline   #3 Reply With Quote
Krimson
Member
 
Join Date: Aug 2011
Location: Calgary
Posts: 60
Send a message via MSN to Krimson Send a message via Yahoo to Krimson Send a message via Skype™ to Krimson

Old April 16th, 2016, 07:46 PM
Custom Monster is great fun! I am going to lose so much time digging out old books and doing conversions. I really like how the Armor Class, Hit Point and Average Damage things give you suggested numbers based on the Challenge Rating of the creature. It makes fleshing out ideas quick and simple. Is there any possibility of doing something similar for player character races?
Krimson is offline   #4 Reply With Quote
Hollis
Senior Member
Lone Wolf Staff
 
Join Date: Aug 2012
Posts: 700

Old April 18th, 2016, 08:19 AM
Quote:
Originally Posted by Mergon View Post
The capability to select a subtype (fey, celestial, or fiend) for a familiar is still missing.
Those are considered type tags in 5e. The menu is right under the types menu.
Hollis is offline   #5 Reply With Quote
Hollis
Senior Member
Lone Wolf Staff
 
Join Date: Aug 2012
Posts: 700

Old April 18th, 2016, 08:20 AM
Quote:
Originally Posted by Mergon View Post
Still getting the following error messages if I have Enable Data File Debugging enabled:



Once again, I removed my data files, the 5e Community files, and completely removed and re-installed HL Still get the errors.
What are you doing when encountering this error? Did you report it to tech support?
Hollis is offline   #6 Reply With Quote
Mergon
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 747

Old April 18th, 2016, 08:25 AM
I reported it during 1.3

It only happens when I save a character with spell casting while I have 'Enable Data File Debugging' active. It doesn't seem to cause any issues other than being annoying. I hate annoying errors that I don't understand.

Watch your back, Conserve your ammo,
and NEVER cut a deal with a dragon!
Mergon is offline   #7 Reply With Quote
Mergon
Senior Member
 
Join Date: Sep 2012
Location: Ottawa, Canada
Posts: 747

Old April 18th, 2016, 08:27 AM
I don't see any place to select or view types on the familiars character sheet when setting up a familiar. Am I missing it somewhere???

Watch your back, Conserve your ammo,
and NEVER cut a deal with a dragon!
Mergon is offline   #8 Reply With Quote
yamatoblaze
Junior Member
 
Join Date: Apr 2016
Posts: 1

Old April 19th, 2016, 01:16 PM
Unless I'm missing something, there is presently no way in the new custom monster builder to define the creature's multiattack options in such a way that the extra damage output will be factored in to the CR estimate.
yamatoblaze is offline   #9 Reply With Quote
lowew79
Member
 
Join Date: May 2012
Posts: 40

Old July 3rd, 2016, 06:08 PM
Quote:
Originally Posted by Mergon View Post
Still getting the following error messages if I have Enable Data File Debugging enabled:



Once again, I removed my data files, the 5e Community files, and completely removed and re-installed HL Still get the errors.
I'm getting the same error, like EXACTLY the same error, down to the line numbers
lowew79 is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:10 PM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.