Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
ErinRigh
Senior Member
 
Join Date: Oct 2016
Posts: 593

Old December 22nd, 2018, 04:43 PM
Well now I know what caused it, the Name field and the alias field were the same, I changed it and one other record that was like that and it imported fine
ErinRigh is offline   #441 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 2,107

Old December 23rd, 2018, 04:14 AM
Quote:
Originally Posted by ErinRigh View Post
Well now I know what caused it, the Name field and the alias field were the same, I changed it and one other record that was like that and it imported fine
Ah, that is good to know. So is it that Realm Works is crashing because the topic name and one of its aliases are exactly the same?

If so, then I can try and put in a check that the topic title and/or any aliases are not the same. It will most likely just report that your import will fail (I think the tool already does this in another situation).

Farling

Author of the Realm Works Import (http://forums.wolflair.com/showthread.php?t=58156) and Output tools (http://forums.wolflair.com/showthread.php?t=59981)
Farling is offline   #442 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 2,107

Old December 23rd, 2018, 05:27 AM
Version 2.1 is available

This version contains an additional check when creating aliases.
A warning message is generated if the alias name matches the name of the main topic or another alias for that topic.
The alias is not added to the RWexport file.
(This prevents a crash of Realm Works during import due to an alias name being duplicated.)

This should help ErinRigh avoid similar problems in the future :-)

Farling

Author of the Realm Works Import (http://forums.wolflair.com/showthread.php?t=58156) and Output tools (http://forums.wolflair.com/showthread.php?t=59981)
Farling is offline   #443 Reply With Quote
ErinRigh
Senior Member
 
Join Date: Oct 2016
Posts: 593

Old December 23rd, 2018, 10:24 AM
Thanks Farling, like geology, you rock
ErinRigh is offline   #444 Reply With Quote
Happydevil43
Senior Member
 
Join Date: Apr 2014
Location: Perth, Australia
Posts: 143

Old December 25th, 2018, 07:45 PM
Not sure if I am doing something wrong or what...

I have a csv file that has all the columns in it, I have the associated structure file.
When I do an import with both the suffix, prefix and other name fields, RW gets to either 55 or 85% and crashes or I get the attached message when generating. If I remove the suffix and other name fields I get a successful (somewhat - I need to a heap of post processing) import.

Any ideas ? I am sure it must be me doing something wrong.

I've uploaded the csv file for reference too.
Attached Images
File Type: jpg import_error.JPG (125.7 KB, 8 views)
Attached Files
File Type: zip Chapter 1 Import.zip (65.3 KB, 4 views)
Happydevil43 is offline   #445 Reply With Quote
ErinRigh
Senior Member
 
Join Date: Oct 2016
Posts: 593

Old December 26th, 2018, 04:29 AM
Hey, I was just figuring out the same, Happy. Apparently, RW doesn't like it if you have 2 name fields with the same name. For example, I had Thrasher as a name field (surname) and Dale as a suffix (given name) so it would sort it Thrasher (Dale) but then I had Thrasher in the True Name field as well (his callsign) and it crashed the program (RW) when I tried to import so Farling created this version to warn you that it will crash RW
ErinRigh is offline   #446 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 2,107

Old December 27th, 2018, 12:36 AM
Quote:
Originally Posted by Happydevil43 View Post
Not sure if I am doing something wrong or what...

I have a csv file that has all the columns in it, I have the associated structure file.
When I do an import with both the suffix, prefix and other name fields, RW gets to either 55 or 85% and crashes or I get the attached message when generating. If I remove the suffix and other name fields I get a successful (somewhat - I need to a heap of post processing) import.

Any ideas ? I am sure it must be me doing something wrong.

I've uploaded the csv file for reference too.
Hi Happy,

The warning window is letting you know that the output file has the same named topic more than once. This probably isn't what you intend in your final realm.

This has previously been caused by one or more topic types being created where the parentage that has been set ends up with creating multiple topics.

--

I've just tried with your XLSX and a default structure for pathfinder, and I originally got your error but then realised that I'd started setting up the "adventure area" topic with the name column as well as the "Location" topic type. When I went back to the adventure area and deleted the column name from the name box (right click on the field in the structure panel) the export file was created properly.

(The tool allows you to set up multiple different topic categories for the same output file, so that you don't have to do multiple imports for a single realm.)

Farling

Author of the Realm Works Import (http://forums.wolflair.com/showthread.php?t=58156) and Output tools (http://forums.wolflair.com/showthread.php?t=59981)

Last edited by Farling; December 27th, 2018 at 12:50 AM.
Farling is offline   #447 Reply With Quote
Happydevil43
Senior Member
 
Join Date: Apr 2014
Location: Perth, Australia
Posts: 143

Old December 28th, 2018, 12:09 AM
Thanks guys for your help - baby steps.. .at least I have that problem sorted... so I decided to get adventurous...

I wanted to have an import file that used the storyline topic, but rename the heading and import text.

so I created a new csv file with the headings:
parent, name, prefix, section title 1, section 1 text, section 1 text 2 etc

I then used the storyline topic (I created a copy and added a couple of text snippets)..
The file generated fine, but when I import I got :

Encountered validation error for the import XML: The 'name' attribute is invalid - The value '' is invalid according to its datatype 'urn:lonewolfdevel.com:realm-works-export:name_type' - The actual length is less than the MinLength value.

Attempt to deactivate a record that is still dirty and needs to be saved


I have attached a screenshot of what I did, I am not sure if this is right or not... I am learning my trial and error...

I've posted the same on the RW facebook page too...just in case somebody has advice.

I fully admit that I am playing and learning..... :-)
Attached Images
File Type: jpg sectionhelp1.JPG (63.2 KB, 4 views)

Last edited by Happydevil43; December 28th, 2018 at 12:12 AM.
Happydevil43 is offline   #448 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 2,107

Old December 28th, 2018, 12:20 AM
It might be that one of your names is " (a single double-quote character) or it might contain only white space (spaces, tabs, line breaks).

Farling

Author of the Realm Works Import (http://forums.wolflair.com/showthread.php?t=58156) and Output tools (http://forums.wolflair.com/showthread.php?t=59981)
Farling is offline   #449 Reply With Quote
Happydevil43
Senior Member
 
Join Date: Apr 2014
Location: Perth, Australia
Posts: 143

Old December 28th, 2018, 12:39 AM
Quote:
Originally Posted by Farling View Post
It might be that one of your names is " (a single double-quote character) or it might contain only white space (spaces, tabs, line breaks).
found it..... damn nabbit….. was a hidden character that was upsetting it. The only way I could find it was to copy the text from excel into word and turn on hidden stuff....

First test was successful... trying now with a bigger file.
Happydevil43 is offline   #450 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:30 AM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.