Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 10th, 2020, 05:45 PM
Initial import works fine. However, if I re-import (due to an added snippet or article) it crashes 100% of the time. Anyone having similar issues? Multiple computers, beta build.

See http://forums.wolflair.com/showthread.php?t=63654 for how I do imports/exports.
nightpanda2810 is offline   #1 Reply With Quote
daplunk
Senior Member
 
Join Date: Jan 2016
Location: Adelaide, Australia
Posts: 2,257

Old January 10th, 2020, 06:33 PM
Have you installed the patch in the sticky?

Realm Works - Community Links
Realm Work and Hero Lab Videos
Ream Works Facebook User Group
Realm Works - Community Content List
CC3+ Facebook User Group

D&D 5e Community Pack - Contributor
General Hero Lab Support & Community Resources
D&D 5e Community Pack - Install Instructions / D&D 5e Community Pack - Log Fault / D&D 5e Community Pack - Editor Knowledge Base
daplunk is offline   #2 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 10th, 2020, 06:39 PM
Yup, on 255. Error I get is "object reference not set to an instance of an object"

Note this is happening on 2 realms, game system one that's huge, and world one that's really small in comparison.

Been doing a bunch of testing since I posted. Created new realms with minor changes and imported fine. Seems my 2 big realms are somehow corrupt. One I can rebuild in a couple of hours. The other has over 2000 articles in it, no rebuilding that one... Literally months worth of work in it.
nightpanda2810 is offline   #3 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,688

Old January 11th, 2020, 12:22 AM
Before you do that, had you edited any of the imported topics in the destination realm?

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is offline   #4 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 11th, 2020, 08:50 AM
With the realm I first noticed the issue with I have no idea. Hasn't been touched in months.

However, part of the testing I did tested this.
Created a blank realm.
Created a new export of the affected realm with no changes.
Imported into the blank realm without issue.
Added a new topic to the source realm and exported. No other modifications.
Imported into the no longer blank realm, and got a crash.

These crashes happen whether I use overwrite settings or not.
nightpanda2810 is offline   #5 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 11th, 2020, 09:46 AM
Just had a couple of successful imports. Downgrade to build 253 did the trick.

Export files created with 253 worked without issue.

Export files created with 255 do not work, however an expected error due to version numbers rather than a crash.
nightpanda2810 is offline   #6 Reply With Quote
Thorkull
Junior Member
 
Join Date: Sep 2011
Posts: 20

Old January 30th, 2020, 11:57 AM
Good info, just ran into this myself last night. I'll try downgrading when I get home. Has anyone tested with 254?
Thorkull is offline   #7 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 30th, 2020, 12:00 PM
Quote:
Originally Posted by Thorkull View Post
Good info, just ran into this myself last night. I'll try downgrading when I get home. Has anyone tested with 254?
254 has its own import/export bug (unsure if related to this) so I didn't try with it.

Side note, I did open a support case when this happened. Haven't had a resolution yet, but have gotten responses. You should open one as well (and anyone else with this) so they're aware it's not just me
nightpanda2810 is offline   #8 Reply With Quote
Thorkull
Junior Member
 
Join Date: Sep 2011
Posts: 20

Old January 30th, 2020, 08:46 PM
Will do -- where can I get the build 253 installer?

Last edited by Thorkull; January 30th, 2020 at 08:49 PM.
Thorkull is offline   #9 Reply With Quote
nightpanda2810
Senior Member
 
Join Date: Jun 2016
Posts: 174

Old January 31st, 2020, 09:29 AM
Quote:
Originally Posted by Thorkull View Post
Will do -- where can I get the build 253 installer?
I lucked out by changing the build number in the download link for 255.

https://www.wolflair.com/download/rw...53_install.exe
nightpanda2810 is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:56 AM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.