Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Online Forums > HLO - Starfinder

Notices

Reply
 
Thread Tools Display Modes
gravedancer
Junior Member
 
Join Date: Oct 2017
Posts: 3

Old September 10th, 2021, 04:16 PM
I had previously bought the Starfinder core module and added it to my HLO patron account. It shows up fine. Ive created a campaign, but before going to add creatures to it I purchased alien archive, and most of the other currently available starfinder content. However, when I go to create a custom race or monster, and i get blue warning text that basically tells me im gimped and need to go purchase alien archive to get the full list of options (despite having already purchased Alien archive.

For example:

Hero: The range of CRs to choose from is currently restricted to CR 3 or less, or +/-2 around the normal CR if you are adjusting a pre-built monster. Purchasing Alien Archive will grant you access to the full list of options.

Creature Type Graft: The list of type grafts to choose from is currently restricted to a few examples. Purchasing Alien Archive will grant you access to the full list of options.

and similar messages around just about every option.

Ive verified that Alien Archive SF1 and Alien Archive 2 SF1 both show up as "Packages added to your account" in the management tool. Ive tried clearing browser cache. Ive also tried using a different browser that had never even been used to log into HLO before. Even tried using a different computer entirely. No change.

Anyone else seen this before and know of a fix ive not thought of ?
gravedancer is offline   #1 Reply With Quote
gravedancer
Junior Member
 
Join Date: Oct 2017
Posts: 3

Old September 10th, 2021, 04:40 PM
After starting this topic I had the thought " I wonder if the issue has anything to do with the campaign already being created before I bought Alien Archive?"

Apparently that is the case. I created a new campaign and it does not have the issues I described above. Apparently if you add new content after creating a campaign it is not fully pulled in (some stuff was, as the list of monsters to "import from vault" expanded after I added alien archive).
gravedancer is offline   #2 Reply With Quote
Mathias
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 12,948

Old September 10th, 2021, 04:51 PM
On both the campaign and this monster, you should be able to turn on Alien Archive in the character settings. Since this campaign was created on an account that did not own Alien Archive, it started out with Alien Archive turned off, and all characters/NPCs created in the campaign will default to the settings on the campaign.
Mathias is offline   #3 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 10:18 PM.


Powered by vBulletin® - Copyright ©2000 - 2021, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.