Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
Absintheminded78
Member
 
Join Date: Jan 2016
Location: Sydney, Australia
Posts: 47

Old April 17th, 2017, 12:55 PM
Hi Farling,

I'm importing into a new Pathfinder realm. My steps were:
  • Create a new Pathfinder Realm
  • Add copies of relevant categories (Feats, Magic Items)
  • Export that realm's structure
  • Create the .rwexport file with your tool
  • Import that back into the realm I created
How do I have more than one column appear in a field? e.g. with Feats you have Benefit but also Normal and Special. Is it possible to add more than one column to a field? Or is that part of the initial copying of the category? To add any missing fields before exporting the structure? (I think I know the answer to this already now after thinking about it )
Also, I couldn't see a picture in your post sorry.

Thanks for your help, I'll do another one using the selector now that I know what I'm doing haha.
Absintheminded78 is offline   #11 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 1,305

Old April 17th, 2017, 03:16 PM
It is curious because I followed your steps above; except that I imported into a different realm. Maybe it is the re-import into the same realm that is the problem, I will try it out.

At the moment there is only one column per field.

Hopefully you can see the picture as an attachment now.

It is on the TODO to allow the creation of labelled_Text snippets, and also to intermix columns with entered text.

I'm trying to produce an updated version that fixes a slight error when you have both a snippet tag and an annotation in the field. I'm struggling with the installer (the code is already fixed). So in v1.0.0 either set up the tag or the annotation, but not both.

Last edited by Farling; April 17th, 2017 at 03:19 PM.
Farling is offline   #12 Reply With Quote
Absintheminded78
Member
 
Join Date: Jan 2016
Location: Sydney, Australia
Posts: 47

Old April 17th, 2017, 04:10 PM
Thanks Farling, I can now see the picture too. I'll try again and create a new .rwexport file using the tags in the selector.

I'm starting to think that maybe there is an issue with my Realm Works as I had altered EightBitz's spell import script to do the magic items and received the same error about the category not existing but when I checked it in XML Notepad and compared it to my spells import file the structure and content were almost identical (except of course relevant category, tag and facet ID's, it was set to the correct one for Magic Items - category_4).
I'll do some more testing, did you manage to get my file to import ok?
Absintheminded78 is offline   #13 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 1,305

Old April 17th, 2017, 04:26 PM
Importing into the same realm won't work at the moment. This is due to me using "Tag_1" as the tag for the new import, but Realm Works has already used this for the export of the structure which was performed.

I tried using a tag id of "MyImportTag" but this caused Realm Works to crash (reported), after reporting about an error during import.

I don't think it's anything that I can fix at my end for the moment.

Last edited by Farling; April 17th, 2017 at 05:06 PM.
Farling is offline   #14 Reply With Quote
ErinRigh
Senior Member
 
Join Date: Oct 2016
Posts: 418

Old April 17th, 2017, 06:11 PM
Does this mean we are limited to one import with your tool?
ErinRigh is offline   #15 Reply With Quote
davidp
Senior Member
Lone Wolf Staff
 
Join Date: Jun 2011
Posts: 1,058

Old April 17th, 2017, 06:25 PM
Quote:
Originally Posted by Farling View Post
Importing into the same realm won't work at the moment. This is due to me using "Tag_1" as the tag for the new import, but Realm Works has already used this for the export of the structure which was performed.

I tried using a tag id of "MyImportTag" but this caused Realm Works to crash (reported), after reporting about an error during import.

I don't think it's anything that I can fix at my end for the moment.
If you are referring to the tag_id values, they are only used during the import and as long as you don't duplicate them within the import file for different <tag> elements, it should work fine. Even if you are referring to the "name" on the tag in the import file, it should still work fine, although it would be confusing.

As far as the crash, if you haven't done so yet, please open a support ticket, also, so we can track it and contact you directly with more questions.
davidp is offline   #16 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 1,305

Old April 18th, 2017, 12:00 AM
Quote:
Originally Posted by davidp View Post
As far as the crash, if you haven't done so yet, please open a support ticket, also, so we can track it and contact you directly with more questions.
Hi David,
I have now raised a support ticket (two actually, one from my old email and one from my new email - Case 119499 and Case 119500).
It is curious that the import works into a new realm just not the original realm.

It all seems related to handling of the import_tag_id.

Last edited by Farling; April 18th, 2017 at 12:56 AM.
Farling is offline   #17 Reply With Quote
Farling
Senior Member
 
Join Date: Mar 2013
Location: Greater London, UK
Posts: 1,305

Old April 18th, 2017, 12:06 AM
Quote:
Originally Posted by ErinRigh View Post
Does this mean we are limited to one import with your tool?
Hello ErinRigh,

No, not at all, the import tool will create one file per category, so you would create one file for each of your different topic/article categories.

Each of these files can then be imported into the same realm.

I have a further tweak to make to the program where you can specify the name of the import (or have it automatically generated), rather than it always being called "Test Import".

The only limitation at the moment, which I've now identified in the first post, is that you can't import into the same realm from which you generated the structure-only export.
Farling is offline   #18 Reply With Quote
ErinRigh
Senior Member
 
Join Date: Oct 2016
Posts: 418

Old April 18th, 2017, 07:06 AM
Hey farling, I got v1.0 to work and imported a file (YaY) but I tried to import another file made with v1.1 and got an error

The following errors were encountered during import:

Encountered validation error for the import XML: The element 'contents' in namespace 'urn:lonewolfdevel.com:realm-works-export' has invalid child element 'section' in namespace 'urn:lonewolfdevel.com:realm-works-export'. List of possible elements expected: 'topic, plot_group, view' in namespace 'urn:lonewolfdevel.com:realm-works-export'.

The following considerations arose during import...

Adding tag PFSpells (Structure Only) to domain Import


Here is a dropbox link with my files if you want to check through them;

https://www.dropbox.com/s/12ax8a7h2z...ells1.zip?dl=0
ErinRigh is offline   #19 Reply With Quote
craghammer
Member
 
Join Date: Dec 2015
Location: Oslo, Norway
Posts: 33

Old April 18th, 2017, 12:07 PM
Getting a lot of errors with this tool, but did manage to get it working on occasion. I do see that when I generate a rwexport file, sometimes the XML structure get's jumbled (</export> tag appears after a <topic> tag). And then I get the same as ErinRigh.
Keep up the good work, this tool IS awesome, if it works
craghammer is offline   #20 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:17 PM.


Powered by vBulletin® - Copyright ©2000 - 2017, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.