Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
Acenoid
Senior Member
 
Join Date: Dec 2013
Posts: 525

Old April 15th, 2017, 04:11 PM
All the best, trust me I can imagine in what situation youre in.
I'll send you a pm anyway,once you have time again just let me know

Join the (unofficial) Realm-Works IRC Chat: #realm-works on the Rizon Network (https://wiki.rizon.net/index.php?title=Servers)
-> Browser Client: https://kiwiirc.com/client/irc.rizon.net
Acenoid is online now   #151 Reply With Quote
KaribouOfDoom
Junior Member
 
Join Date: Jul 2017
Posts: 2

Old July 23rd, 2017, 12:16 AM
Quote:
Originally Posted by EightBitz View Post
First, make sure you have the current version, which is 1.5.

Second, if you're selecting Word as the output format, change your destination file to have a .doc or .docx extension.

Other than that, I'm not sure. Is anyone else besides ArgoForg having these issues?
Hi. First post here, so please excuse any general lack of understanding that I might have. I've read this thread and documentation thoroughly and I'm having the same issue as ArgoForg. Did you decide that this issue is the known bug of having a blacked-out-but-revealed smart snippet? My world is still very small, so I went in and "un-revealed" any snippet that might have qualified as a trigger for the bug, and I'm getting the same error. I'd really love for this to work.

Help?
KaribouOfDoom is offline   #152 Reply With Quote
KaribouOfDoom
Junior Member
 
Join Date: Jul 2017
Posts: 2

Old July 23rd, 2017, 09:16 PM
Found the problem. For anyone getting this issue with the "= operator missing" (as reported in ArgoForg's post, the solution is to make sure you're running version 4.5 of the .Net framework and then download and install version 5.0 of Windows Management Framework. This will update PowerShell and the error will go away.
KaribouOfDoom is offline   #153 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,105

Old August 14th, 2017, 08:49 PM
Finally updated, folks. I know a couple of you have been waiting patiently for these fixes. I apologize for the long delay, and I appreciate your patience.

See the top post or read the release notes.
EightBitz is offline   #154 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,105

Old August 14th, 2017, 08:58 PM
Quote:
Originally Posted by KaribouOfDoom View Post
Found the problem. For anyone getting this issue with the "= operator missing" (as reported in ArgoForg's post, the solution is to make sure you're running version 4.5 of the .Net framework and then download and install version 5.0 of Windows Management Framework. This will update PowerShell and the error will go away.
Thank you for finding this solution.
EightBitz is offline   #155 Reply With Quote
tmilktoast
Junior Member
 
Join Date: Jun 2014
Location: Wisconsin, USA
Posts: 16

Old August 16th, 2017, 08:58 AM
Eightbitz,

There is a minor(ish) issue you may want to know about. The script errors out when confronted by an empty Labeled Text snippet. I have quite a few of those which I intend to fill in, of course, but right now they are sort of empty placeholders.

Ultimately, all that data will be filled in when I export this for real and the script will work properly, so it's not a big deal. I just thought you might want to know.

Here is the error code:
Code:
[ERROR]
     Command Line: &(".\RWExport-To-HTML.ps1") -Source 'D:\Owncloud\RPG\Utilities\RWExport\SWSkills 0.2.rwoutput' -Destination 'D:\Owncloud\RPG\Utilities\RWExport\skill02.html' -Sort 4 -SimpleImageScale 0 -SmartImageScale 0 -CSSFileName 'RWExport_091b_1.6.css' -Format 'HTML' -Prefix -Suffix -Details -Indent -KeepStyles -Force
         Reason: InvalidOperation - You cannot call a method on a null-valued expression.

       Location: Line 741, Character 17
    Script Line: $InsertPoint = $Text.IndexOf($TagPreface) + $TagPreface.Length

          Topic: Brawl
        Section: Overview
   Snippet Type: Labeled_Text
[/ERROR]
tmilktoast is offline   #156 Reply With Quote
Rabit
Junior Member
 
Join Date: Sep 2010
Posts: 20

Old September 12th, 2017, 05:49 PM
First, EightBitz, thank you SO much for creating this!

Question: Has anyone been able to get the ExtractFiles function to work? Is there a trick to it that I'm missing? I've tried everything I can think of, but it doesn't work. It just fails (no error or anything), and subsequent attempts (until I reboot) give me an error (see attached).

Any assistance is greatly appreciated!

If it helps/matters, here's what I'm using (and yes, that folder is empty except for the CSS and the "realm_files" subfolder):
-Source 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw.rwoutput' -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw' -Sort 4 -SimpleImageScale 0 -SmartImageScale 0 -CSSFileName 'RWExport_091b_1.6.css' -Format 'HTML' -Prefix -Suffix -Indent -KeepStyles -ExtractFiles -Force

I've also tried "... -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw\'..." but that hasn't worked, either.
Attached Files
File Type: txt error.txt (9.3 KB, 4 views)
Rabit is offline   #157 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,105

Old September 13th, 2017, 01:50 AM
Quote:
Originally Posted by Rabit View Post
First, EightBitz, thank you SO much for creating this!

Question: Has anyone been able to get the ExtractFiles function to work? Is there a trick to it that I'm missing? I've tried everything I can think of, but it doesn't work. It just fails (no error or anything), and subsequent attempts (until I reboot) give me an error (see attached).

Any assistance is greatly appreciated!

If it helps/matters, here's what I'm using (and yes, that folder is empty except for the CSS and the "realm_files" subfolder):
-Source 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw.rwoutput' -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw' -Sort 4 -SimpleImageScale 0 -SmartImageScale 0 -CSSFileName 'RWExport_091b_1.6.css' -Format 'HTML' -Prefix -Suffix -Indent -KeepStyles -ExtractFiles -Force

I've also tried "... -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw\'..." but that hasn't worked, either.
Take off the -Force option, and add a -Log option. So, something like this:

-Source 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw.rwoutput' -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw' -Sort 4 -SimpleImageScale 0 -SmartImageScale 0 -CSSFileName 'RWExport_091b_1.6.css' -Format 'HTML' -Prefix -Suffix -Indent -KeepStyles -ExtractFiles -Log 'c:\users\russ\saltmarsh_export.log'
EightBitz is offline   #158 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,105

Old September 18th, 2017, 02:50 AM
Quote:
Originally Posted by Rabit View Post
First, EightBitz, thank you SO much for creating this!

Question: Has anyone been able to get the ExtractFiles function to work? Is there a trick to it that I'm missing? I've tried everything I can think of, but it doesn't work. It just fails (no error or anything), and subsequent attempts (until I reboot) give me an error (see attached).

Any assistance is greatly appreciated!

If it helps/matters, here's what I'm using (and yes, that folder is empty except for the CSS and the "realm_files" subfolder):
-Source 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw.rwoutput' -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw' -Sort 4 -SimpleImageScale 0 -SmartImageScale 0 -CSSFileName 'RWExport_091b_1.6.css' -Format 'HTML' -Prefix -Suffix -Indent -KeepStyles -ExtractFiles -Force

I've also tried "... -Destination 'C:\Users\russ\Documents\GAMING\Saltmarsh Campaign\_RW Info\saltmarsh_rw\'..." but that hasn't worked, either.
OK, no word back from Rabit. Is anyone else having this issue?
EightBitz is offline   #159 Reply With Quote
Acenoid
Senior Member
 
Join Date: Dec 2013
Posts: 525

Old September 18th, 2017, 03:18 PM
The other issues prevent me from proceeding a bit. Still not certain were the problem lies Any news rgd. job?

Join the (unofficial) Realm-Works IRC Chat: #realm-works on the Rizon Network (https://wiki.rizon.net/index.php?title=Servers)
-> Browser Client: https://kiwiirc.com/client/irc.rizon.net
Acenoid is online now   #160 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:17 PM.


Powered by vBulletin® - Copyright ©2000 - 2017, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.