Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
thelizardofodd
Junior Member
 
Join Date: Jan 2013
Posts: 4

Old February 25th, 2017, 09:19 AM
Hey folks,
I'm fairly new to RealmWorks, and have had an ongoing issue I've been unable to find an answer to. When I first got it and started toying around, I made an article for one of my races. I then traveled for the holidays, came back, and have no idea where that article is. I thought I had it in the 'Characters' section of the Mechanics reference, but it's not visibly there.
So, I re-created it, but now whenever I type that race and it tries to link it, it brings up both items...the new (filled out) one which is correctly located in the mechanics reference, and the old empty one that's sitting...somewhere?
Any idea where to find items that don't appear to have any container? I've searched each section in the most obvious ways without luck...
Thanks!
thelizardofodd is offline   #1 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,688

Old February 25th, 2017, 03:15 PM
The obvious solution is to create a topic with a snippet containing the term and let the linker link to the "wrong" article and then follow the link.

If that doesn't work then I think you've got a bug.

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is online now   #2 Reply With Quote
thelizardofodd
Junior Member
 
Join Date: Jan 2013
Posts: 4

Old February 25th, 2017, 03:39 PM
Yeah I did try this...I can get to the article easily, but then have no means of deleting it from within the article itself. :/
thelizardofodd is offline   #3 Reply With Quote
Silveras
Senior Member
 
Join Date: Aug 2010
Posts: 1,521

Old February 25th, 2017, 05:51 PM
You could also use the magnifying glass to search by text for it (filters the navigation pane list to show only only matches).

Also, although you think you did it in Mechanics, it could be in World Almanac .. so search/filter both to be sure.
Silveras is offline   #4 Reply With Quote
thelizardofodd
Junior Member
 
Join Date: Jan 2013
Posts: 4

Old February 25th, 2017, 07:56 PM
I've tried the magnifying glasses, in pretty much every category I can find. When I link to the old dud article, and then click my way into it, it shows itself as being contained in nothing. It can link to things, and be linked to, but has no container, and I can't delete it from within the article itself. :/

Edit: Here's an image for some reference to what I mean - http://i.imgur.com/lJ3DBCc.png

On the left is the normal right side-bar for a character (Jaromir). I linked to the dud article in this character (you can see the two articles on the bottom right), and when I click into it, the right side-bar shows no containing topic information. If I could figure out how to either delete it from within the article, or move it to a container from within the article, I'd be fine. Until then, it's just floating around and I have to pick which kožat I want every time I link to the race (which wouldn't be so annoying if it didn't default to the wrong one).

Last edited by thelizardofodd; February 25th, 2017 at 08:06 PM. Reason: Added image w/additional notes
thelizardofodd is offline   #5 Reply With Quote
Parody
Senior Member
 
Join Date: Jan 2013
Location: Rochester, MN
Posts: 1,377

Old February 25th, 2017, 09:09 PM
While there are a couple of Topic/Article types that can't be contained and thus lose the Containing Topic/Article section of the Relationships Pane (notably Story Source, Mechanics Source, and the Realm Starting Point) I don't believe you could have gotten them to use the alien head icon. The two Sources would show up in their respective main views (World Almanac and Mechanics Reference) and you can get to the Realm Starting Point by clicking the house-in-a-circle icon below the Ribbon.

You can show the current Topic/Article in the Navigation Pane by opening the Content Pane Options menu (F7) and picking Show in Current Navigation (or Ctrl-=). However, you'll need to be in a view that can show it (so World Almanac for Topics and Mechanics Reference for Articles) and you need to not have any filters that might hide it. This also won't work for the Realm Starting Point, as it never shows in Navigation.

Assuming none of what we've said so far helps you find your lost Topic/Article, I recommend you get in touch with LWD (at support@wolflair.com or by writing up a bug report) and work with them to figure out what's going on. Let us know what happens!

Last edited by Parody; February 25th, 2017 at 09:54 PM. Reason: Getting my facts straight.
Parody is offline   #6 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,458

Old February 25th, 2017, 10:21 PM
You can change your view to show a flat list of topics by category.

If you really want to nuke it and can find no other way, you can do a full export of the realm, then open the export file with Notepad++ and search for the name of the topic, see if it shows up twice. If it does, you can manually delete the empty copy from the export file, create a new realm, and import the fixed export file into the new realm.
EightBitz is offline   #7 Reply With Quote
thelizardofodd
Junior Member
 
Join Date: Jan 2013
Posts: 4

Old February 26th, 2017, 12:02 PM
Hey folks,

I've sent an email to support, as I've had no luck with any new suggestions. I even noticed that if you grab the tab of an article up top, it looks like you can drag it into a container on the left (an arrow appears), but nothing happens for me (with any of my articles).
Thanks for the offered assistance, I will be sure to offer an update once a solution is discovered.
thelizardofodd is offline   #8 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 740

Old February 28th, 2017, 03:32 AM
I notice the article contains a z with an inverted circumflex - maybe that does not sit well with RW.

On the other hand, I think I have some articles with weird letters as well.

Just thinking out loud here.

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #9 Reply With Quote
kbs666
Senior Member
 
Join Date: Oct 2014
Location: Chicago, IL
Posts: 1,688

Old February 28th, 2017, 04:48 AM
RW is supposed to handle all text in Unicode and in my testing, which admittedly hasn't been more than cursory it does. It certainly has no problem with any of the symbols in a couple of my Unicode fonts that I've tried.

You should keep in mind that this is based on the HTML standard and on the installed fonts on the machine rendering the text so when exporting a realm do not expect things like nonstandard scripts like Elvish or Klingon which have unofficial Unicode pages to appear correctly.

my Realm Works videos
https://www.youtube.com/channel/UCZU...4DwXXkvmBXQ9Yw
kbs666 is online now   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:57 AM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.