Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
Bloodwolf
Member
 
Join Date: Dec 2013
Posts: 98

Old December 9th, 2016, 09:36 AM
I just had the new 218 version crash twice one me. I traced the crash to custom links. The first time it crashed without warning when I want to save a topic. The second time I saved the same topic several times without a crash but when I tried to save it with two new custom links in the topic to save it crashed again. After that crash I saved after creating each custom link and it did not crash. So it looks like for some reason when it has to do multiple custom links it crashed.

Just to be clear my realm is rather large because I am bringing 1e Temple of Elemental Evil up to 3.5. Current topic number is 1254.
Bloodwolf is offline   #11 Reply With Quote
Grey Mage
Senior Member
 
Join Date: Feb 2011
Posts: 297

Old December 9th, 2016, 11:52 AM
I haven't had it crash yet, but found a bug (already reported) within 5 minutes of using it.

If you have a link that also contains bold text, upon saving, the bold goes away.

Anyone else having this issue?
Grey Mage is offline   #12 Reply With Quote
Little Paris
Member
 
Join Date: Feb 2013
Posts: 35

Old December 9th, 2016, 01:46 PM
I tried to update all of my realms. All worked but one: I tried to update one specific realm several times, but it always crashed....

I still have to check, if the allready updated realms will be really working. Thankfully the one not working at all is not in use at the moment at the game table....
Little Paris is offline   #13 Reply With Quote
rob
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 8,190

Old December 9th, 2016, 02:17 PM
We're putting out a new version with a couple bug fixes shortly. I believe we'll have fixes in place for the above-mentioned issues.
rob is offline   #14 Reply With Quote
rob
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 8,190

Old December 9th, 2016, 04:15 PM
New build 219 is out. This fixes a few bugs in build 218. I believe it fixes the ones identified above.
rob is offline   #15 Reply With Quote
Little Paris
Member
 
Join Date: Feb 2013
Posts: 35

Old December 10th, 2016, 08:11 AM
I was very hopeful when Rob announced the new fixes. Unfortunately, it did not solve my problem, but I hope you will figure out an solution. As I said it is not very urgent, but it would be a shame to lose the data. Thankfully it is one of my smaller realms...
Little Paris is offline   #16 Reply With Quote
wurzel
Senior Member
 
Join Date: Mar 2013
Location: Germany
Posts: 155

Old December 10th, 2016, 04:18 PM
Update today took 1 Minute for a 1.2 GB Database. Obviously I didn't have any strange topics.
RW crashed once again during play today. Somehow it could not send the error report due to some problems. That has never happened before. http://forums.wolflair.com/images/smilies/confused.gif
Was too busy keeping my players in line so I could not record the error messages. If it occurs again I'll try to put together a summary.


DM: Tol'Uluk - game system independent homebrew world (so far AD&D 2, D&D3.5, Fate, Pathfinder, D&D5)
Tools: RW, CC3+, CD3, DD3, HL
RL: Retired senior IT manager. Now just housewife, grandma and fantasy author.
wurzel is offline   #17 Reply With Quote
rob
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 8,190

Old December 11th, 2016, 04:20 PM
Quote:
Originally Posted by Little Paris View Post
I was very hopeful when Rob announced the new fixes. Unfortunately, it did not solve my problem, but I hope you will figure out an solution. As I said it is not very urgent, but it would be a shame to lose the data. Thankfully it is one of my smaller realms...
Make sure to provide us with your database. Send us a link to it. Something very special is going on with your realm, so we'll need to see exactly what it is.
rob is offline   #18 Reply With Quote
kate
Member
 
Join Date: Aug 2013
Posts: 41

Old December 31st, 2016, 12:14 PM
I never updated to build 218, but tried to update to 219 today.

When I try to do the database fixup on my realm, I get "Error deserializing span list" and Realm Works crashes.

I've sent an error report but I'm curious if anyone else is getting this error - and considering revering to an earlier Realm Works version since this is my main realm and I'll want to use it again shortly after the holidays.

EDIT: Husband has the player version and is getting "C++ Exception: Failed to locate lookup entry at line 1215 in file utility.cpp." I'm pretty sure the cloud version he's trying to access isn't fully updated if that would make a difference.

Last edited by kate; December 31st, 2016 at 12:19 PM. Reason: More info
kate is offline   #19 Reply With Quote
EightBitz
Senior Member
 
Join Date: May 2013
Posts: 1,457

Old January 5th, 2017, 07:43 PM
Is it possible to implement a "Fix-All" button, or something equivalent, so when database fix-ups are needed for a new release, we don't have to go through one realm at a time?
EightBitz is offline   #20 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 02:10 AM.


Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.