Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
ibecker
Member
 
Join Date: Oct 2013
Posts: 76

Old October 17th, 2015, 03:12 PM
Since I upgraded to 1.0.1043, I've discovered that Realm Works will no longer suggest a 2-character "Other Name" as a link target. For example, when "ST" appears in a snippet (an "Other Name" for the "Strength" topic, set to Case-Sensitive matching at Normal priority), Realm Works now ignores "ST", and doesn't offer a link for it.

Has anyone else noticed this? Is it a bug, or is there now a 3-character minimum (which does still work) for links?

-Ian
ibecker is online now   #1 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 743

Old October 17th, 2015, 09:31 PM
Well, just tried creating an individual with the name of "Ib" - when saving it pops up a requester telling me that for auto link detection to work it needs at least three characters.

So, it does not look like a bug but as intended behaviour - I have no idea what technical reasons there might be that causes issues with the auto link feature.

I don't know if this is new - this is the first two-character topic I have entered as far as I remember.

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #2 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 743

Old October 17th, 2015, 09:47 PM
Well-well-well....

I just tried something else...

I wrote the above character "Ib" into another topic to see if it made a link. It didn't. So I right-clicked "Ib" and selected "Create new custom link for selection". This apparently worked as it should.

I then added "Ib" in another snippet and selected "Create new custom link for all instances of selection". This caused an immediate crash.

Full crash report has been sent.

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #3 Reply With Quote
AEIOU
Senior Member
 
Join Date: Jan 2012
Posts: 1,127

Old October 18th, 2015, 01:20 PM
That's humorous in a twisted sense. Pop-up says use three. You force two. Program throws a hissy fit, takes its ball and goes home leaving you high and dry. That'll teach you!

More seriously, thanks for pushing the envelope and uncovering the issue.
AEIOU is offline   #4 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 743

Old October 18th, 2015, 09:24 PM
:-)

Well, not sure my bug report ever reached its destination; shouldn't I get an automated reply-mail?

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #5 Reply With Quote
ibecker
Member
 
Join Date: Oct 2013
Posts: 76

Old October 19th, 2015, 07:27 AM
Interesting - I've never created a Topic or Article with only a 2-character name, but I have a lot of 2-character aliases (now, 'Other Names'), and I've relied on those aliases working for linking purposes. (In GURPS, 2-character abbreviations like 'ST' for 'Strength' of a character or 'Strength' required to use a weapon, and 'TL' for 'Technology Level' of a setting or 'Technology Level' of a weapon, are used everywhere.) They've been working fine up to this point. If those no longer work for automatic linking, that will be a serious annoyance for my workflow.
ibecker is online now   #6 Reply With Quote
ibecker
Member
 
Join Date: Oct 2013
Posts: 76

Old October 19th, 2015, 07:41 AM
It also occurs to me: Why shouldn't a 2-character name for a Topic or Article be legitimate? What if I were using the D&D dragon god 'Io' or the 'Bo' weapon in my game? Those names should certainly work for linking purposes.
ibecker is online now   #7 Reply With Quote
liz
Ex-Staff
Lone Wolf Staff
 
Join Date: Jul 2013
Posts: 983

Old October 19th, 2015, 08:42 AM
Quote:
Originally Posted by Vargr View Post
:-)

Well, not sure my bug report ever reached its destination; shouldn't I get an automated reply-mail?
We've received support cases about this, but your forum email address is not the same as the ones that have contacted us about this issue. Check your spam folder in your email client to see if the automatic reply was sent there. Our emails should be coming from tracker@wolflair.com.
liz is offline   #8 Reply With Quote
Vargr
Senior Member
 
Join Date: Apr 2014
Location: Denmark
Posts: 743

Old October 19th, 2015, 11:29 AM
@Liz

Nowhere to be found.

Well, apparently the report got lost somewhere on its way.

However, since you have other reports concerning this problem, I will assume you have what you need to to look into the problem.

And thank you for taking the time to reply :-)

Vargr
Deputy Calendar Champion


Legend has it, that the Tarrasque is a huge fighting beast, perpetually hungry.
Sleet entered History when he managed to get on the back of a Tarrasque only to be ridden out of History shortly after.

Using Realm Works, Worldographer (Hexographer 2), LibreOffice, Daz3D Studio, pen & paper for the realm World of Temeon and the system LEFD - both homebrewed.

Vargr is offline   #9 Reply With Quote
liz
Ex-Staff
Lone Wolf Staff
 
Join Date: Jul 2013
Posts: 983

Old October 19th, 2015, 01:32 PM
Quote:
Originally Posted by Vargr View Post
@Liz

Nowhere to be found.

Well, apparently the report got lost somewhere on its way.

However, since you have other reports concerning this problem, I will assume you have what you need to to look into the problem.

And thank you for taking the time to reply :-)
To clarify, you receive an automated response when you submit a bug report through this form or send an email to support@wolflair.com. You don't receive an automated response when you submit a crash report. If you want a follow-up on a crash report that you send in, you should definitely send an email to support@wolflair.com.
liz is offline   #10 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 06:21 AM.


Powered by vBulletin® - Copyright ©2000 - 2018, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.