Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Hero Lab Forums > HL - D&D 5th Edition SRD

Notices

Reply
 
Thread Tools Display Modes
Fenris447
Senior Member
 
Join Date: Sep 2017
Posts: 535

Old March 4th, 2022, 02:24 PM
Quote:
Originally Posted by Nightfox View Post
Not sure if this is a bug, or I'm just missing something, but it seems that the skill selection from the Prodigy feat is pervasive. Once a skill is selected in the "Proficiencies" tab, the skill is on the character. It cannot be deleted in the proficiencies tab, and even if you delete the feat, the character still shows as being proficient with the skills that had been selected.

Is there some way around this, or do I need to go back and recreate the character?
I have no idea why it does that. But you can right click on your selection in the proficiencies tab for an option to delete it.

Found an issue with or have a suggestion for the 5e Community Pack? Please post it here at our GitHub.

Feel free to stop by the Lone Wolf Development Subreddit, for discussion of any and all LWD products and community efforts!
Fenris447 is offline   #971 Reply With Quote
Nightfox
Member
 
Join Date: Dec 2011
Posts: 81

Old March 4th, 2022, 03:42 PM
Quote:
Originally Posted by Fenris447 View Post
I have no idea why it does that. But you can right click on your selection in the proficiencies tab for an option to delete it.
Thank you. Right click was always for debugging so I completely overlooked the delete option.
Nightfox is offline   #972 Reply With Quote
Fenris447
Senior Member
 
Join Date: Sep 2017
Posts: 535

Old March 4th, 2022, 03:46 PM
Quote:
Originally Posted by Nightfox View Post
Thank you. Right click was always for debugging so I completely overlooked the delete option.
I'm pretty sure I asked the exact same question here years ago So I'm glad I remembered the solution!

I'm adding a note to the Prodigy Feat to hopefully head off the same issue in the future.

Found an issue with or have a suggestion for the 5e Community Pack? Please post it here at our GitHub.

Feel free to stop by the Lone Wolf Development Subreddit, for discussion of any and all LWD products and community efforts!
Fenris447 is offline   #973 Reply With Quote
Nightfox
Member
 
Join Date: Dec 2011
Posts: 81

Old March 4th, 2022, 05:18 PM
I see where Prodigy and Skilled feats use the "call 5CAddProf" procedure. Which in turn references the configurable [cfg5CProf], but it is just a "childfound" I cannot figure out how it is adding the config tab. I was hoping to do some debug tests, but right now it looks like a backend issue.

more testing done:
Made a copy of the cfg5CProf and did some tests by adding 1 possible for each of the 3 skills and 3 tools. Skill1 and all 3 tools have the little (x) but skill2 and skill3 do not.

Note: Even though the lines did not have the easy remove function (x), the proficiency bonus went away when test feat that generated it was deleted. I think this may be due to the fact that cfg5CProf is pre-added to the hero, where as the copy I created had to be added by bootstrap on the feat and therefore disappeared when the feat was removed.

next test, make a clean (non-copy) of config page to see if we get the same results.

Last edited by Nightfox; March 4th, 2022 at 05:36 PM. Reason: new tests
Nightfox is offline   #974 Reply With Quote
Nightfox
Member
 
Join Date: Dec 2011
Posts: 81

Old March 4th, 2022, 05:58 PM
It looks like a back-end issue for how the configuration pages handle the second and third groups of skills.
Attached Images
File Type: png Skill-Tool_ConfigTab.png (288.6 KB, 3 views)
Nightfox is offline   #975 Reply With Quote
Fenris447
Senior Member
 
Join Date: Sep 2017
Posts: 535

Old March 4th, 2022, 06:31 PM
That's really good to know! I knew roughly how the Prof tab is pre-bootstrapped and that call 5CAddProf worked, but I never bothered testing to see where the issue lied. I try to avoid utilizing that tab in general. And when I do add skill choices in Configurables, I'm practically always using just the first skill chooser. But now I know to avoid the second and third like the plague!

Found an issue with or have a suggestion for the 5e Community Pack? Please post it here at our GitHub.

Feel free to stop by the Lone Wolf Development Subreddit, for discussion of any and all LWD products and community efforts!
Fenris447 is offline   #976 Reply With Quote
BilboH20s
Junior Member
 
Join Date: Feb 2011
Posts: 11

Old March 5th, 2022, 05:52 PM
I am having an issue with the Homunculus Servant Infusion for my Level 3 Artificer. When choosing Homunculus Servant, is has the wrong blurb. It says "Grant a ring the ability to restore a spell slot." It does add the Homunculus Servant to the Dashboard, but it has validation errors. When I click on the Homunculus Servant, it comes up for me to build it instead of it being prebuilt. It wants me to add a Race, but no Races are available to choose from. It also wants me to choose the Ability Scores from the Standard Array and an Alignment. It also has 0/0 HP and 10 AC. I have verified I'm using the D&D 5e Community Pack 3.5.
BilboH20s is offline   #977 Reply With Quote
BilboH20s
Junior Member
 
Join Date: Feb 2011
Posts: 11

Old March 6th, 2022, 10:18 PM
I found another issue. After choosing the Race of Human, when I go to add a Variant, none of the Marks show their details. The only info it shows is: Mark of (its name) Appears In: Wayfinder's Guide of Eberron , Eberron - Rising from the Last War. It happens with all of the Variant Marks under Human. The other Races that can choose Marks all have the info listed. Also, none of the Marks will automatically add the Spells of the Mark to the character's Spell List, regardless of Race chosen. I tried with just selecting Wayfinder's Guide of Eberron and again with only selecting Eberron - Rising from the Last War. Both do the same thing.
BilboH20s is offline   #978 Reply With Quote
Fenris447
Senior Member
 
Join Date: Sep 2017
Posts: 535

Old March 13th, 2022, 06:57 PM
Quote:
Originally Posted by BilboH20s View Post
I am having an issue with the Homunculus Servant Infusion for my Level 3 Artificer. When choosing Homunculus Servant, is has the wrong blurb. It says "Grant a ring the ability to restore a spell slot." It does add the Homunculus Servant to the Dashboard, but it has validation errors. When I click on the Homunculus Servant, it comes up for me to build it instead of it being prebuilt. It wants me to add a Race, but no Races are available to choose from. It also wants me to choose the Ability Scores from the Standard Array and an Alignment. It also has 0/0 HP and 10 AC. I have verified I'm using the D&D 5e Community Pack 3.5.
Two issues here: summary text is indeed wrong; I'm fixing it for the next patch.

The other problem is with sources. The homunculus servant has those issue for you because when it's created, it automatically selects whatever set of sources you have set as your default (on the Configure Hero screen, ctrl+K). If Eberron is not a default source for you, then it won't be able to find the servant's race and therefore show up how it's showing up for you. I'll fix it to automatically inherit your artificer's sources. In the mean time, while you're viewing the Homunculus, press ctrl+K, select Eberron as a source, and you should see everything look the way it's supposed to.

Found an issue with or have a suggestion for the 5e Community Pack? Please post it here at our GitHub.

Feel free to stop by the Lone Wolf Development Subreddit, for discussion of any and all LWD products and community efforts!
Fenris447 is offline   #979 Reply With Quote
Fenris447
Senior Member
 
Join Date: Sep 2017
Posts: 535

Old March 13th, 2022, 07:42 PM
Quote:
Originally Posted by BilboH20s View Post
I found another issue. After choosing the Race of Human, when I go to add a Variant, none of the Marks show their details. The only info it shows is: Mark of (its name) Appears In: Wayfinder's Guide of Eberron , Eberron - Rising from the Last War. It happens with all of the Variant Marks under Human. The other Races that can choose Marks all have the info listed. Also, none of the Marks will automatically add the Spells of the Mark to the character's Spell List, regardless of Race chosen. I tried with just selecting Wayfinder's Guide of Eberron and again with only selecting Eberron - Rising from the Last War. Both do the same thing.
There's a few things going on here.

Regarding the subraces vs variants showing all the benefits; herolab automatically takes all the features that a subrace gets and lists them when you look at that subrace in the selection menu. For some reason, it doesn't do the same thing with variants. The variants still get all their benefits, they're just not listed. Neither the subraces nor the variants have any text entered by me (or any other programmer) that manually lists this stuff.

Could we? Yes. But here's why I don't spend time doing that. Ultimately, the Community Pack should be a tool to assist you in using content you already own or otherwise have legitmate access to. If it was supposed to be an alternative to buying that content, then it would be a competitor and basically be liable for action by WotC. So I tend to err on the side of "you should already know what this subrace has because you can look at your or your DM's book".

As for the spells, I can't reproduce your error. I re-tested a bunch of the Marks and found they are correctly adding to the spell lists. It may be a matter of you interpreting the Marks differently. When something gets added to your spell list, that doesn't automatically mean you now know/have memorized/have prepared the spell. It just means that spell is now added to the pool of spells you can choose from when learning/preparing spells. IE a cleric picking his spells for the day can pick from both the regular cleric spell list AND whatever spells his or her Mark provided. In that regard, the Marks are functioning as intended.

Found an issue with or have a suggestion for the 5e Community Pack? Please post it here at our GitHub.

Feel free to stop by the Lone Wolf Development Subreddit, for discussion of any and all LWD products and community efforts!
Fenris447 is offline   #980 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 09:59 AM.


Powered by vBulletin® - Copyright ©2000 - 2022, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.