Lone Wolf Development Forums  

Go Back   Lone Wolf Development Forums > Realm Works Forums > Realm Works Discussion

Notices

Reply
 
Thread Tools Display Modes
rob
Senior Member
Lone Wolf Staff
 
Join Date: May 2005
Posts: 7,951

Old February 21st, 2017, 02:04 AM
Quote:
Originally Posted by Greebo View Post
I am not sure, if it is related, but I have a minor bug regarding fonts. Some versions ago RW introduced invisible characters of a symbol font into my snippets. IIRC I filed a support ticket back then. The behavior disappeared after a version upgrade.

Since a week or two, the behavior reappeared. RW sets invisible characters in the font DajaVu Math Tex Gyre at the beginning and end of some snippets and at the beginning and end of text I copy into snippets via Paste.
Please make sure you open a support ticket about this and include as much detail as you can discern about what's going on. I'm not sure what could be happening from the description, but it sure sounds bizarre.
rob is offline   #21 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old February 22nd, 2017, 08:29 AM
Quote:
Originally Posted by rob View Post
Please make sure you open a support ticket about this and include as much detail as you can discern about what's going on. I'm not sure what could be happening from the description, but it sure sounds bizarre.
Bug reported.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #22 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old March 11th, 2018, 04:05 AM
Quote:
Originally Posted by Greebo View Post
I am not sure, if it is related, but I have a minor bug regarding fonts. Some versions ago RW introduced invisible characters of a symbol font into my snippets. IIRC I filed a support ticket back then. The behavior disappeared after a version upgrade.

Since a week or two, the behavior reappeared. RW sets invisible characters in the font DajaVu Math Tex Gyre at the beginning and end of some snippets and at the beginning and end of text I copy into snippets via Paste.
The problem reappeared again. This time, RW sets the characters or spaces in the font Amiri. And it seems to happen most frequently whenever I duplicate a topic. But RW does also tend to re-insert those spaces after I have deleted them by hand and saved the topic.

Shall I open an new support ticket?


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #23 Reply With Quote
Rone
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2017
Posts: 200

Old March 13th, 2018, 07:22 AM
Greebo, yes, please do submit a new support ticket.
Rone is offline   #24 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old March 14th, 2018, 12:20 AM
Quote:
Originally Posted by Rone View Post
Greebo, yes, please do submit a new support ticket.
Done.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #25 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old March 19th, 2018, 08:44 AM
Amendment: The characters seem to get set i.a. during linking.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #26 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old March 20th, 2018, 08:22 AM
And whenever I add a snippet in the same section of a topic.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #27 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old January 9th, 2019, 03:52 AM
Update: The bus still persists in RW Version .250. Everytime I save a topic RW sets an invisible character in the font Amiri at the very beginning of every edited snippet.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #28 Reply With Quote
Rone
Senior Member
Lone Wolf Staff
 
Join Date: Dec 2017
Posts: 200

Old January 9th, 2019, 07:24 AM
Quote:
Originally Posted by Greebo View Post
Update: The bus still persists in RW Version .250. Everytime I save a topic RW sets an invisible character in the font Amiri at the very beginning of every edited snippet.
Curiouser and curiouser...

Although we've had reasons to use invisible characters, we think there's been cases where particular fonts interfered with those characters being hidden away and unnoticeable.

It might help if you went through your fonts to see if any particular one is interfering. Any that are installed as part of Windows should be safe, but if you installed any custom fonts, perhaps one of them is interacting with Realm Works in an interfering way?

And if you happen to locate such a meddlesome font... please let us know what it is.

Realllly hoping it's not a font called "Meddlesome."
Rone is offline   #29 Reply With Quote
Greebo
Senior Member
 
Join Date: Aug 2013
Location: Germany
Posts: 226

Old January 9th, 2019, 08:39 AM
Never noticed it before you mentioned particular fonts as possible cause, Rone, but my LotR Realm using Tahoma as standard font does behave properly, whereas my science fantasy realm using a font called Shadowrun as standard snippet style shows the bug.


Supporting Calendar Campaigner

Tools: Realm Works, Campaign Cartographer 3+ and Add-ons, MapTools
Games: home brew world, Lord of the Rings (CODA), Shadowrun, Earthdawn
Greebo is offline   #30 Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:24 AM.


Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.