View Single Post
Janrith
Member
 
Join Date: Mar 2019
Location: Pacific Northwest, USA
Posts: 52

Old March 23rd, 2020, 09:47 PM
(I've tried this on 253, 254 AND 255...)

Scenario:

I have a base realm that I'm using to build out some rulesets (call them A, B and C). Each is setup with their own partial export definition, and export successfully. Exported the structure of this base realm as well.

Created a new blank realm based on the original structure. I was able to import A and B, but C hit a null reference exception.

For each import, overwrites were turned on, and original ownership is being preserved.

OK, started over...

Another new blank realm with structure, imported B and C successfully. Tried to import A and again hit a null reference exception.

Taking out B and attempting to import either A then C, or C then A both attempts resulted in the null reference exceptions.

I've also tried the imports with and without dependencies, to no avail.

Questions:

Why would two exports that came from the same realm import successfully on their own, but have problems being imported in succession into a new target realm?

In each case, the import took 20-30 minutes, hit ~95%+ before triggering the exception.

I'm speculating there's perhaps a category definition that isn't being exported, but shouldn't all the categories have been in the structure file?

As there are no other diagnostic tools available, or logging messages to tell me what the problem is, I'm at a complete loss.

If anyone has any suggestions, or ways of getting more information, I'd appreciate it.

Thanks.

-=Janrith
Janrith is offline   #1 Reply With Quote