Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Army Builder (http://forums.wolflair.com/forumdisplay.php?f=16)
-   -   I just upgraded to AB3.2 and.... (http://forums.wolflair.com/showthread.php?t=9016)

PO232 August 11th, 2009 08:02 AM

I just upgraded to AB3.2 and....
 
I can't access most of the data files I currently have downloaded. I get syntax error messages and AB shuts down giving me the following error: C:\Docume~1\Daniel~1\Locals~1\Temp\wderror5720.txt
I was using AB3.1 just prior to the upgrade and had no problems. I've tried re-loading the files and this doesn't work. My license is fine, and some of the larger files are available for use.
Anyone else having this problem??:eek:

PO232 August 11th, 2009 08:08 AM

The effected files on my system are Aeronautica Imperialis, Battle Fleet Gothic, Necromunda and Warhammer 40K 4th Edition.

rob August 11th, 2009 08:59 AM

The error messages are due to your copy of AB being configured for data file debugging (i.e. authoring data files) instead of running as a simple user. With the switch to V3.2, the compiler is now doing much better error checking of data files, so errors that slipped through in V3.1 are now being caught and reported. All of this extra checking is only turned on when data file debugging is enabled (for authors). When that is turned off, all V3.1 data files should load properly in V3.2.

So the solution is to load a game system that is safe (e.g. the sample files), go to the Developer menu, and turn off data file debugging. After that, you should be good to go.

shaggai August 11th, 2009 04:45 PM

The AB40K maintainer have just posted a new general release which handles this small problem. You may download it from: http://www.ab40k.org/modules.php?nam...=getit&lid=139.

After an initial testing period, the general release will be available for download (with the possibility of additional corrections) through the AB's "NEW UPDATES" mechanism.

PO232 August 11th, 2009 09:00 PM

Thanks
 
I want to thank Rob and Shaggai for their help. I disabled the debugging and downloaded the general release and now I have my files back. A big thanks guys!!!:):)

freddy326 August 17th, 2009 10:56 PM

same problem
 
Hi,

I've got the same problem with Flames of War files, but when I load the sample file and go to the develop menu, the debugger doesn't appear to be enabled.

the only options I have are 'Enable Datafile debugging' and 'enable skin debugging'

anyone got any ideas about how to fix the problem?

Colen August 19th, 2009 12:52 PM

freddy326, can you describe exactly which data files you're using, and what problem is occurring? I just downloaded the Flames of War v1.0 data files from the updates mechanism, and it seems to be working perfectly for me.

freddy326 August 20th, 2009 10:42 PM

AB 3.2 problem
 
Hi,

I upgraded from 3.1C to 3.2 and have retained the original Flames of war, flames of war 2 files. I've downloaded the flames of war 3 data files as well.

The fow 3 file crashes Army builder from the main menu, I can open the original flame of war list, create an army and then save it. If I try to reload it then crashes out.

I tried switching game systems from within the application that let me get into the saved file once.

Colen August 26th, 2009 03:13 PM

When AB crashes, it should tell you where to find a file with the crash information. Can you copy and paste the contents of that file into here, so we can take a look at them? That should hopefully help us diagnose things.

Thanks!


All times are GMT -8. The time now is 12:32 AM.

Powered by vBulletin® - Copyright ©2000 - 2022, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.