Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Warmaster (http://forums.wolflair.com/forumdisplay.php?f=45)
-   -   Creating rules (http://forums.wolflair.com/showthread.php?t=20048)

stevothedivo March 10th, 2012 01:21 PM

Creating rules
 
Hey guys
still working on WMA Renaissance lists I've got it almost down pat.
Unfortunately I can't get the Lim/Max validation rule to work!
What can I be doing wrong?!?!
Definition filename is iwf, unit names are iwfFreXbow and iwfGend

Copying from the other (working) def files I have:
1. created a new rule with the unique ID as rule name under the Rule tab
2. Entered unique ID, scope and priority (no warning box tick)
3. Entered text to be read "One xxx required per 1000pt"
4. Entered roster.iwf
5. Entered (with no "" or italics)
"if (tagcount[unitid.iwfFreXbow] > 0) then
@valid = 1
done
endif
~ minimums do not apply to armies under 1000 points
if (tagvalue[roster.size?] < 1000) then
@valid = 1
endif"

6. Gone to Unit tab and set a limits rule of min1
7. Saved, exited ABC, opened AB3.0 (license paid, no pirating btw....)
8. I start my new roster and warnings read
"Army must contain only one General
One French Crossbowmen per 1000pt are required
One Gend d'Armes per 1000pt are required"
9. When I buy a General that message disappears. When I buy one of the other two units they don't. HOWEVER if I buy more than the limit allowed (say 3 per 1000pt) it does come up in red, which means it's working IN PART....

Bho...what am I doing wrong please?!
Thanks!
S.

Dredemer December 17th, 2014 02:30 PM

Nice...😄


All times are GMT -8. The time now is 04:40 PM.

Powered by vBulletin® - Copyright ©2000 - 2017, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.