Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Realm Works Discussion (http://forums.wolflair.com/forumdisplay.php?f=67)
-   -   Minimum Required Build Change Back to 253 and Import/Export Issues In Builds 255-256 (http://forums.wolflair.com/showthread.php?t=65964)

SteveT May 28th, 2021 06:28 PM

Minimum Required Build Change Back to 253 and Import/Export Issues In Builds 255-256
 
There are a variety of threads out there already discussing these topics, but I felt it would be best if I created a new one as a central place for me to respond and provide information and hopefully reduce some confusion.

For reference, these are the main threads I am aware of related to this (there may be some that I’m missing):

https://forums.wolflair.com/showthread.php?t=65903
https://forums.wolflair.com/showthread.php?t=64732
https://forums.wolflair.com/showthread.php?t=63665
https://forums.wolflair.com/showthread.php?t=63509

Based on reports from certain users regarding problems they have been experiencing with import/export in builds 255-256 that were not present in build 253, we have now updated the server to no longer require build 256 to access it. Build 253 is now the minimum required build for the time being.

In the coming days I’ll be working to gather some more information from the users who have reported import/export problems that didn’t exist in build 253 but emerged in builds 255-256. If you experienced these problems in builds 255-256, it would be most helpful if you could do a structure-only export of the realms you are having issues exporting and provide the .rwstructure file in a support ticket, and ideally post your support case number in this thread so I can find it quickly. (NOTE! Build 254 had a different import/export issue that was fixed in build 255, so please don’t do this if you experienced issues in build 254 only. Only issues that exist in builds 255-256 but were not present in build 253 are relevant).

Unfortunately, if you choose to not upgrade to build 256 and instead remain on builds 253-255, integration with Hero Lab Classic will not work correctly due to changes on the server that were made to work with build 256. Attempting to view or edit Hero Lab Classic portfolios externally will fail with an error message. There are some workarounds, however.

If you need to get a portfolio out of RW, you can launch the 32-bit version of Hero Lab Classic and activate it using your Hero Lab Classic device code/license number (you need activate the 32-bit version separately from the 64-bit version). Then within Realm Works, use the play button dropdown menu and choose the “Open Within Hero Lab” option, or use the “Click to integrate into running program” button. Realm Works will display an error message saying “Unable to integrate the external object.” However, in this case the error message is incorrect, and the portfolio will in fact be imported into Hero Lab Classic. So you can simply ignore the error message from Realm Works. In Hero Lab Classic, you can then save the portfolio as a file to your disk after making whatever changes you want to it.

If you need to get a portfolio back into RW, you can clear the existing portfolio data on the snippet (or create a new portfolio snippet), and use the “Load from File” option.

Build 253 can be downloaded from:

https://www.wolflair.com/download/rw...53_install.exe

However, it will not work with a database that has been opened with builds 254-256. In that situation, if all your local data is synced with the server and you don’t have any local changes you want to keep, you can move or delete your local database file and then run the installer and sync everything back down from the server. If you need assistance doing this, please contact support at support@wolflair.com. Unfortunately, if you have local changes that have NOT been synced with the server that you are unable to sync with the server, there is no workaround currently available to go back to build 253 if you have already run with builds 254-256.

Maidhc O Casain May 29th, 2021 10:27 AM

Hi, Steve. I sent in a support ticket this morning with a Savage Worlds structure only export from build 256. I've haven't messed with import/export yet - I haven't had a realm I was ready to do anything like that with. But hopefully any data you can get from the one I sent will help.

The support ticket number is 267476.

Acenoid May 30th, 2021 09:50 AM

Really cool to see some updates / really needed fixes for RW! I upgraded to the latest version at the time, but no idea if these bugs were present in 253.... and there is no workaround getting back from 256 :/

I will read through the threads that you stated youre aware baout but maybe, can someone list the bugs that we DO NOT have to report?

nightpanda2810 June 2nd, 2021 09:15 AM

Here's a case number from January 2020: 252158

SteveT June 2nd, 2021 05:45 PM

Thank you, nightpanda I appreciate it. I've re-opened your case and have some more specific questions for you there.

Janrith June 4th, 2021 04:47 PM

I cleansed my system of the 255 binaries and all the 254+ associated structure and import files when I reverted to 253 as I needed a working system.

From what I can tell, I can't run 253 in parallel with 255 or 256 for that matter in order to to repro the scenario and yet keep a working environment for my system without having to cleanse the master db and resync back from the server.

The issue I kept hitting which prevented upgrading past 253 however is very succinctly explained by Acenoid here:

http://forums.wolflair.com/showpost....36&postcount=7

SteveT June 7th, 2021 01:23 PM

@Janrith

The structure exports I'm looking for don't need to be generated by build 255/256. Structure exports generated by build 253 would be fine and would be helpful to me. I need to look at the structures of the realms that are having issues and having the structure export file would greatly help that process.

Farling June 7th, 2021 02:02 PM

Quote:

Originally Posted by SteveT (Post 295351)
@Janrith

The structure exports I'm looking for don't need to be generated by build 255/256. Structure exports generated by build 253 would be fine and would be helpful to me. I need to look at the structures of the realms that are having issues and having the structure export file would greatly help that process.

I've seen a new error message during import, "Cannot modify protected category". I don't know if this was ever in an earlier version, but it can cause problems for existing users.

SteveT June 7th, 2021 03:31 PM

Quote:

Originally Posted by Acenoid (Post 295256)
I will read through the threads that you stated youre aware baout but maybe, can someone list the bugs that we DO NOT have to report?

At the moment, the specific error I'm looking at is "object reference not set to an instance of an object" on import using build 255 or 256. This seems to be the one that emerged in build 254 and is still present in builds 255/256.

So, this is the one for which I'm looking for structure exports for the realms whose export files experienced this error.

Madmaxneo June 7th, 2021 05:26 PM

Quote:

Originally Posted by Farling (Post 295355)
I've seen a new error message during import, "Cannot modify protected category". I don't know if this was ever in an earlier version, but it can cause problems for existing users.

Quote:

Originally Posted by SteveT (Post 295356)
At the moment, the specific error I'm looking at is "object reference not set to an instance of an object" on import using build 255 or 256. This seems to be the one that emerged in build 254 and is still present in builds 255/256.

So, this is the one for which I'm looking for structure exports for the realms whose export files experienced this error.

The error that Farling mentions above is from my current experience.

At this moment I can no longer import anything into RW because of this issue. I tried a few things based on Farlings recommendations and nothing worked. I did discover another potential issue though.

I have several protected categories that I turned off protection on and then modified, which seems to be the reason why it will not let me import anything anymore.

My realm is still a "Legacy" game system. I tried copying the realm but RW crashed during the copy process. I was able to convert the realm directly into "Other" game system, but after doing so I was unable to export anything, be it a full realm or just the structure. I then restored my realm with the backup to the "Legacy" game system.

I am wondering at this point if there is a setting that you changed in this recent update (256) that made it so I (the end user) can't change protected categories or snippets? I unprotected and changed a lot of the categories in RW for my preferred game system.

If this is the case, is there any chance it will be changed so I can import into categories that have the protection turned off and many of the tags altered?


All times are GMT -8. The time now is 09:09 PM.

Powered by vBulletin® - Copyright ©2000 - 2022, vBulletin Solutions, Inc.
wolflair.com copyright ©1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.