Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Realm Works Discussion (http://forums.wolflair.com/forumdisplay.php?f=67)
-   -   RealmWorks CSV Import Tool (http://forums.wolflair.com/showthread.php?t=58156)

Farling April 18th, 2017 02:54 PM

Quote:

Originally Posted by craghammer (Post 248270)
Getting a lot of errors with this tool, but did manage to get it working on occasion. I do see that when I generate a rwexport file, sometimes the XML structure get's jumbled (</export> tag appears after a <topic> tag). And then I get the same as ErinRigh.
Keep up the good work, this tool IS awesome, if it works :)

Hi Craghammer, is it possible for you to send me a copy of the rwexport file and/or some lines from the original CSV and the rwstructure file?

I want to track down how the tags are getting out of step, since I didn't think it would be possible.

Farling April 18th, 2017 03:40 PM

V1.2 has just been posted which fixes a problem with the generation of the closing tags when a snippet was left blank.

The installer also adds the application to the Start Menu.

The Q.A. department has been sacked! Normal service will resume shortly.

Absintheminded78 April 18th, 2017 04:16 PM

Quote:

Originally Posted by Farling (Post 248278)
The Q.A. department has been sacked! Normal service will resume shortly.

Haha :D

I'll give v1.2 a go. Interestingly I managed to get a Feats export to work properly. I created a new Structure Realm and a new Test Realm and generated a feats .rwexport file that imported with no issues. I then tried with the magic items csv file and encountered the same issue as craghammer where the xml tags are out of order.
As I said I'll attempt with v1.2 and see how it goes.

Loving the tool btw

ErinRigh April 18th, 2017 05:04 PM

1.2 seems to have fixed my problem, thanks Farling, keep up the great work, mate

craghammer April 19th, 2017 12:30 AM

Quote:

Originally Posted by Farling (Post 248276)
Hi Craghammer, is it possible for you to send me a copy of the rwexport file and/or some lines from the original CSV and the rwstructure file?

I want to track down how the tags are getting out of step, since I didn't think it would be possible.

Hi Farling, looking into the CSV file, I've noticed it has a lot of special characters in the text, and that is probably messing up the import. Working through it and it looks better and better when importing.

Is it possible/easy/hackable, to add all imported items to a containing article? In my case, importing a few hundred items/articles, it would help having them in a container.

Farling April 19th, 2017 11:19 AM

Quote:

Originally Posted by craghammer (Post 248296)
Is it possible/easy/hackable, to add all imported items to a containing article? In my case, importing a few hundred items/articles, it would help having them in a container.

I could add it to the TODO list.

I already know the format of the XML file that would do this.

The difficult bit is designing how to present this to a non-technical user in a friendly manner. :-)

Farling April 19th, 2017 12:30 PM

Craghammer, your wish is my command, have a look at v1.3.1

Less than 90 minutes, thanks to the wonders of Qt :-)

With some proper validation entered so that people don't try to do silly things :-)

ErinRigh April 19th, 2017 01:58 PM

Quote:

Originally Posted by Farling (Post 248326)
Craghammer, your wish is my command, have a look at v1.3.1

Less than 90 minutes, thanks to the wonders of Qt :-)

With some proper validation entered so that people don't try to do silly things :-)

This is BRILLIANT, save me HOURS of work, you are the MAN

craghammer April 19th, 2017 09:53 PM

Farling, you rock! :D

Absintheminded78 April 19th, 2017 11:30 PM

I don't know what the hell is wrong with my one :mad:
Every time I do one now I get an error after about 10% import that the category doesn't exist. (Realm Works crashes at the error)
I've tried multiple combos of realm structure and import realm but still no luck. e.g. created two new realms - one for structure, one for import - tested - error.
Tried that multiple times with different export files, even doing a smaller amount of topics (just general feats) but always gives me grief :mad:
Anyone able to share a file they've created to see if I get the same error with your file?
Thanks


All times are GMT -8. The time now is 01:34 AM.

Powered by vBulletin® - Copyright ©2000 - 2019, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.