Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Realm Works Discussion (http://forums.wolflair.com/forumdisplay.php?f=67)
-   -   Foundry loose integration (http://forums.wolflair.com/showthread.php?t=65924)

Farling February 6th, 2022 01:46 PM

Quote:

Originally Posted by Sword_of_Spirit (Post 298163)
I found one more glitch. I tried to change the setting for "Location of Extracted Assets" from the default to a different folder (in this case Data/media/realmworksimport), and it ruined the import. Only 4 or 5 scenes made it in, and it didn't look like any journal entries made it in. (Lots of errors in the console naturally.) Worked fine in the default location.

I'd be interested in seeing the first few errors in the console. One of the early ones might indicate why it doesn't like the supplied location.

Did you mean that the settings panel now says,

[data] media/realmworksimport

Or did you actually select "Data/media/realmworksimport" from the folder picker?

Sword_of_Spirit February 7th, 2022 06:35 PM

Quote:

Originally Posted by Farling (Post 298225)
I'd be interested in seeing the first few errors in the console. One of the early ones might indicate why it doesn't like the supplied location.

Did you mean that the settings panel now says,

[data] media/realmworksimport

Or did you actually select "Data/media/realmworksimport" from the folder picker?

That's strange. It worked this time. The time it didn't work it actually uploaded the files to the correct folder--it just didn't finish implementing them or the journals in the world.

It's the former path. Maybe I did the latter last time? I don't know. Maybe there was just a glitch.

Farling February 15th, 2022 01:55 AM

Quote:

Originally Posted by Sword_of_Spirit (Post 298244)
That's strange. It worked this time. The time it didn't work it actually uploaded the files to the correct folder--it just didn't finish implementing them or the journals in the world.

It's the former path. Maybe I did the latter last time? I don't know. Maybe there was just a glitch.

It's good to hear that it is working now though :-)

Sword_of_Spirit August 9th, 2022 09:35 PM

I'm not sure if you need any sort of heads up for this, but Foundry v10 will be on the release channel soon, and with its journal system completely revamped, there may be tweaks that need to be made to the module for it to work right. Once it's out I'll report any abnormalities I can find.

Farling August 12th, 2022 12:05 PM

Quote:

Originally Posted by Sword_of_Spirit (Post 299739)
I'm not sure if you need any sort of heads up for this, but Foundry v10 will be on the release channel soon, and with its journal system completely revamped, there may be tweaks that need to be made to the module for it to work right. Once it's out I'll report any abnormalities I can find.

I already have the journal code updated - it will have only one page per journal document though. There isn't an easy way to understand which RW topics might be pages within a single journal document.

Actor generation is more difficult, since each supported game system would have to be re-evaluated and tested to ensure that actors are created from the embedded HL portfolios. Actor generation for CoC7 is already working in the V10 version.

I am awaiting each game system to be converted to work with V10 before I can start on converting my importer for that game system (DND5E, PF1, SWADE)

SLger January 22nd, 2023 12:50 PM

Hello, i use the Realm Works Importer for Foundry VTT and i imported the .por-Files from the pc and nsc - that works, but i can't open their character sheets. Need help!

I use Foundry 10.291 and Realm Work Importer 2.7

Farling January 23rd, 2023 07:49 AM

Quote:

Originally Posted by SLger (Post 300736)
Hello, i use the Realm Works Importer for Foundry VTT and i imported the .por-Files from the pc and nsc - that works, but i can't open their character sheets. Need help!

I use Foundry 10.291 and Realm Work Importer 2.7

Which game system and version of that game system?

I haven't updated the dnd5e importer to support dnd5e v2.1.x, but it should stil work with dnd5e v2.0.x

SLger January 23rd, 2023 08:29 AM

Quote:

Originally Posted by Farling (Post 300737)
Which game system and version of that game system?

I haven't updated the dnd5e importer to support dnd5e v2.1.x, but it should stil work with dnd5e v2.0.x

i use Pathfinder 1 version 0.82.5 for foundry vtt

Farling January 24th, 2023 07:38 AM

Quote:

Originally Posted by SLger (Post 300739)
i use Pathfinder 1 version 0.82.5 for foundry vtt

My test imports seem to work properly in that version of the PF1 system.

Is it possible for you to send me the POR file as a DM so that I can test it.

Also, could you look in the browser console (open with F12 on Windows) in order to see if there are any errors reported during the import process.

Farling January 31st, 2023 05:59 AM

Quote:

Originally Posted by SLger (Post 300739)
i use Pathfinder 1 version 0.82.5 for foundry vtt

I had somebody report an issue, but that was because the update button actually installed version 0.551 of pathfinder 1 rather than a later version.


All times are GMT -8. The time now is 12:54 PM.

Powered by vBulletin® - Copyright ©2000 - 2023, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.