Lone Wolf Development Forums

Lone Wolf Development Forums (http://forums.wolflair.com/index.php)
-   Realm Works Discussion (http://forums.wolflair.com/forumdisplay.php?f=67)
-   -   Another weird import issue I'm troubleshooting. (http://forums.wolflair.com/showthread.php?t=64091)

Janrith March 23rd, 2020 09:47 PM

Another weird import issue I'm troubleshooting.
 
(I've tried this on 253, 254 AND 255...)

Scenario:

I have a base realm that I'm using to build out some rulesets (call them A, B and C). Each is setup with their own partial export definition, and export successfully. Exported the structure of this base realm as well.

Created a new blank realm based on the original structure. I was able to import A and B, but C hit a null reference exception.

For each import, overwrites were turned on, and original ownership is being preserved.

OK, started over...

Another new blank realm with structure, imported B and C successfully. Tried to import A and again hit a null reference exception.

Taking out B and attempting to import either A then C, or C then A both attempts resulted in the null reference exceptions.

I've also tried the imports with and without dependencies, to no avail.

Questions:

Why would two exports that came from the same realm import successfully on their own, but have problems being imported in succession into a new target realm?

In each case, the import took 20-30 minutes, hit ~95%+ before triggering the exception.

I'm speculating there's perhaps a category definition that isn't being exported, but shouldn't all the categories have been in the structure file?

As there are no other diagnostic tools available, or logging messages to tell me what the problem is, I'm at a complete loss.

If anyone has any suggestions, or ways of getting more information, I'd appreciate it.

Thanks.

-=Janrith

Janrith March 24th, 2020 01:17 AM

Curiouser and curiouser...

If I perform a combined export of the two conflicting partials as a single unit, and then import that, it succeeds.

Not as clean as I want since each section doesn't have their own image, description, credits, source, and starting topic. It does at least tell me that they can co-exist outside of the authoring realm.

Now if only I can find out why they don't like to come back together...

-=Janrith

Valyar March 24th, 2020 03:10 AM

Did you send support ticket?

kbs666 March 24th, 2020 10:40 AM

Is the original base realm underlying the export and import realms the same?

Do the imports contain any of the same topics/articles?

Janrith March 24th, 2020 03:09 PM

@Valyar: yes

@kbs666: I started with a blank realm and added the Structure from the original realm, then the exports.

The A and C exports have different topics. They may contain topics/articles that rely on the same underlying category definitions, but there shouldn't be any overlap.

The process I took to create the exports:
1. Define the export (optionally setting dependencies -- doesn't seem to matter).
2. Create a View for the World and Mechanics trees corresponding to the export.
3. Viewing the entire World, add the articles from the export's root node in each high level topic to the export. Repeat for the Mechanics tree.
4. Select the appropriate view, then bulk tag all topics to the associated export tag.
5. Perform a partial export, preserving ownership.

Importing the Exports:

1. Create a new realm with Structure from the original realm, and enter.
2. Import the export file, selecting Overwrite... in both the Content and Structure radio button groups under Advanced Options.
3. First file imports successfully.
4. Rinse and repeat step 2 for the next file:

~95+ percent, I get the "Object not associated with an instance of an object..." error message (Null reference exception).

Note: I'm not sure what the exact point of failure is due to how long the imports take. I'm usually doing something else and periodically check on it.

5. Send Report. I've probably send 10 or more of these, but haven't received a response. I'm not expecting one as I that's a one way debugging mechanism (similar to Dr. Watson), but they might get back to me.

-=Janrith

kbs666 March 25th, 2020 12:29 AM

Try not overwriting the structure during the imports.

Janrith May 30th, 2020 03:02 PM

I periodically continue to troubleshoot this import issue, to no avail.

It appears that I can only import a file once. Even trying to import the same file more than once triggers a null reference exception.

I made a simple export with a Source article and three child general articles.

The first time it imported successfully. Immediately after the import completed, I reran the same import (with Preserve settings), and it crashed after 92%. Attempted again with overwrite settings, still crashed after 92%.

Another test:

Create 1 export file with 1 Source and 1 Child general article. Import to realm without these nodes. Success.
Added one more child node to source realm and added to export.
Switch to target realm and imported new file. Import crashed after 92%. Attempted both Preserver and Overwrite settings.

I've gone through to verify all Topic and Article categories are defined the same between both realms; the target is in fact based on the structure of the source but I wanted to visually verify.

I wish there were more debugging tools to figure out where in the process it is crashing, or more detailed logging to show verbose operation status/failure so I could narrow the field. As it is, the thought of working on my game in RW most days results in me putting it off because I can't get past this issue so I'm really just back to pen and paper...

It's very frustrating.

Janrith May 30th, 2020 05:18 PM

OK, so I feel very much like an idjit.

There were a few stray topics from a different import also included in another.

Since RW doesn't let imported content be deleted from the realm, I'm inferring that attempting to overwrite an imported topic with an import from a different export file was causing RW to crash.

The key here was seeing two export tags on one of my the Mech Ref/Source/Child articles that should have only had one and then a bunch of targeted testing across all 3k articles in the source realm.

I am using a master realm to build out my base rule mechanics and then using that to build out exports to be used in Campaign realms, based on suggestions found on the forum. However, using some articles as a base for others also copied their export tags, which caused the issue.

I went through all of my exports and redefined all of the view/article tag setups to ensure uniqueness.

BTW, a very helpful RW feature here was the Add Tags to Search Filter option of the Custom Search Filter, so I could find the errant export tags and remove them.

So the lesson I'm taking from this is to keep very close eye on the export tags when duplicating articles, especially if you are going to later use them in a different export. It can seriously bite you and be hard to find.

If the devs were still working on this, I'd suggest trapping this error during import rather than crashing, but that's a whole other ball of wax.

Thanks to you folks for your suggestions on troubleshooting this. It did help me narrow the field, albeit slowly.

Take care all!

Acenoid May 31st, 2020 05:00 PM

In general it would be much cooler if RW would provide some choices instead of crashes if somehting unforeseen happens during the export.
E.g. skip affected snippet / topic , put it elsewhere , suggest a fix, etc...

But yeah thats complicated. Ideally the import / export should be foolproof :D

Janrith June 1st, 2020 07:08 PM

I'd be happy with instrumented operations logs to show details at the point of failure.


All times are GMT -8. The time now is 01:32 PM.

Powered by vBulletin® - Copyright ©2000 - 2020, vBulletin Solutions, Inc.
wolflair.com copyright 1998-2016 Lone Wolf Development, Inc. View our Privacy Policy here.